Skip to content

← Actionable
Medium, CVSS 5.3amended

Pannellum has a XSS vulnerability in hot spot attributes

CVE-2026-27210GHSA-8423-w5wx-h2r6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pannellum 2.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pannellum

    Affected
    >= 2.5.0, < 2.5.7
    Fixed in
    2.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-27210: 0.37% estimated exploitation activity in the next 30 days; percentile 30.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The hot spot attributes configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the escapeHTML parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file&mdash;without additional user interaction&mdash;is sufficient to trigger the vulnerability and execute arbitrary JavaScript code, which can, for example, replace the contents of the page with arbitrary content and make it appear to be hosted by the website hosting the standalone viewer HTML file. Patches This has been fixed both in v2.5.7 and in the current development branch. Workarounds Setting the Content-Security-Policy header to script-src-attr 'none' will block execution of inline event handlers, mitigating this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8423-w5wx-h2r6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8423-w5wx-h2r6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27210

Advisory: Pannellum has a XSS vulnerability in hot spot attributes
IDs: CVE-2026-27210, GHSA-8423-w5wx-h2r6
Record: https://patchnext.com/advisories/cve-2026-27210 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pannellum 2.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pannellum: affected >= 2.5.0, < 2.5.7; fixed in 2.5.7

## Suggested inspection (read-only)
- `npm ls pannellum --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pannellum.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8423-w5wx-h2r6 (OSV record GHSA-8423-w5wx-h2r6 lists affected ranges: npm pannellum >=2.5.0 <2.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-8423-w5wx-h2r6 (GitHub-reviewed advisory GHSA-8423-w5wx-h2r6 lists affected ranges: npm pannellum >=2.5.0 <2.5.7)

Commands are suggestions: review each one before running it.

Loading voting…