Skip to content

← Actionable
High, CVSS 8.2amended

Feathers exposes internal headers via unencrypted session cookie

CVE-2026-27193GHSA-9m9c-vpv5-9g85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@feathersjs/authentication-oauth 5.0.40), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27193: 0.40% estimated exploitation activity in the next 30 days; percentile 34.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

All HTTP request headers are stored in the session cookie, which is signed but not encrypted, exposing internal proxy/gateway headers to clients. The OAuth service stores the complete headers object in the session: The session is persisted using cookie-session, which base64-encodes the data. While the cookie is signed to prevent tampering, the contents are readable by anyone by simply decoding the base64 value. Under specific deployment configurations (e.g., behind reverse proxies or API gateways), this can lead to exposure of sensitive internal infrastructure details such as API keys, service tokens, and internal IP addresses. Credits: Abdelwahed Madani Yousfi (@vvxhid) / Edoardo Geraci (@b0-n0-b0) / Thomas Rinsma (@ThomasRinsma) From Codean Labs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9m9c-vpv5-9g85

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9m9c-vpv5-9g85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27193

Advisory: Feathers exposes internal headers via unencrypted session cookie
IDs: CVE-2026-27193, GHSA-9m9c-vpv5-9g85
Record: https://patchnext.com/advisories/cve-2026-27193 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @feathersjs/authentication-oauth 5.0.40. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @feathersjs/authentication-oauth: affected <= 5.0.39; fixed in 5.0.40

## Suggested inspection (read-only)
- `npm ls @feathersjs/authentication-oauth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @feathersjs/authentication-oauth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9m9c-vpv5-9g85 (OSV record GHSA-9m9c-vpv5-9g85 lists affected ranges: npm @feathersjs/authentication-oauth >=0 <5.0.40 (fixed))
- Verified: https://github.com/advisories/GHSA-9m9c-vpv5-9g85 (GitHub-reviewed advisory GHSA-9m9c-vpv5-9g85 lists affected ranges: npm @feathersjs/authentication-oauth >=0 <=5.0.39)

Commands are suggestions: review each one before running it.

Loading voting…