Feathers has an origin validation bypass via prefix matching
CVE-2026-27192GHSA-mp4x-c34x-wv3x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@feathersjs/authentication-oauth 5.0.40), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @feathersjs/authentication-oauth
- Affected
- <= 5.0.39
- Fixed in
- 5.0.40
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mp4x-c34x-wv3x lists affected ranges: npm @feathersjs/authentication-oauth >=0 <5.0.40 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mp4x-c34x-wv3x lists affected ranges: npm @feathersjs/authentication-oauth >=0 <=5.0.39
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-27192: 0.27% estimated exploitation activity in the next 30 days; percentile 19.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The origin validation uses startsWith() for comparison, allowing attackers to bypass the check by registering a domain that shares a common prefix with an allowed origin. The getAllowedOrigin() function checks if the Referer header starts with any allowed origin: This comparison is insufficient as it only validates the prefix. This is exploitable when the origins array is configured and an attacker registers a domain starting with an allowed origin string (e.g., https://target.com.attacker.com bypasses https://target.com). On its own, tokens are still redirected to a configured origin. However, in specific scenarios an attacker can initiate the OAuth flow from an unauthorized origin and exfiltrate tokens, achieving full account takeover. Credits: Abdelwahed Madani Yousfi (@vvxhid) / Edoardo Geraci (@b0-n0-b0) / Thomas Rinsma (@ThomasRinsma) From Codean Labs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mp4x-c34x-wv3x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mp4x-c34x-wv3x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27192 Advisory: Feathers has an origin validation bypass via prefix matching IDs: CVE-2026-27192, GHSA-mp4x-c34x-wv3x Record: https://patchnext.com/advisories/cve-2026-27192 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @feathersjs/authentication-oauth 5.0.40. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @feathersjs/authentication-oauth: affected <= 5.0.39; fixed in 5.0.40 ## Suggested inspection (read-only) - `npm ls @feathersjs/authentication-oauth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @feathersjs/authentication-oauth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mp4x-c34x-wv3x (OSV record GHSA-mp4x-c34x-wv3x lists affected ranges: npm @feathersjs/authentication-oauth >=0 <5.0.40 (fixed)) - Verified: https://github.com/advisories/GHSA-mp4x-c34x-wv3x (GitHub-reviewed advisory GHSA-mp4x-c34x-wv3x lists affected ranges: npm @feathersjs/authentication-oauth >=0 <=5.0.39) Commands are suggestions: review each one before running it.
Loading voting…