Skip to content

← Actionable
Medium, CVSS 6.1amended

NiceGUI vulnerable to XSS via Code Injection during client-side element function execution

CVE-2026-27156GHSA-78qv-3mpx-9cqq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nicegui

    Affected
    <= 3.7.1
    Fixed in
    3.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-27156: 0.20% estimated exploitation activity in the next 30 days; percentile 9.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Several NiceGUI APIs that execute methods on client-side elements (Element.runmethod(), AgGrid.rungridmethod(), EChart.runchartmethod(), and others) use an eval() fallback in the JavaScript-side runMethod() function. When user-controlled input is passed as the method name, an attacker can inject arbitrary JavaScript that executes in the victim's browser. Additionally, Element.runmethod() and Element.getcomputedprop() used string interpolation instead of json.dumps() for the method/property name, allowing quote injection to break out of the intended string context. Attack Vector An attacker crafts a malicious URL with a payload as a query parameter. If the application passes this parameter as a method name to any of the affected APIs, the payload is sent to the client via WebSocket and executed via eval(). Example: /?method=alert(document.cookie) combined with application code like: Impact - Cookie/token theft - DOM manipulation (phishing, fake login forms) - Actions performed…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-78qv-3mpx-9cqq

  2. Revision 1 · created ·

    Published from osv record GHSA-78qv-3mpx-9cqq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27156

Advisory: NiceGUI vulnerable to XSS via Code Injection during client-side element function execution
IDs: CVE-2026-27156, GHSA-78qv-3mpx-9cqq
Record: https://patchnext.com/advisories/cve-2026-27156 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nicegui 3.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nicegui: affected <= 3.7.1; fixed in 3.8.0

## Suggested inspection (read-only)
- `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nicegui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78qv-3mpx-9cqq (OSV record GHSA-78qv-3mpx-9cqq lists affected ranges: PyPI nicegui >=0 <3.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-78qv-3mpx-9cqq (GitHub-reviewed advisory GHSA-78qv-3mpx-9cqq lists affected ranges: PyPI nicegui >=0 <=3.7.1)

Commands are suggestions: review each one before running it.

Loading voting…