Skip to content

← Actionable
High, CVSS 8.9amended

Storybook Dev Server is Vulnerable to WebSocket Hijacking

CVE-2026-27148GHSA-mjf5-7g4m-gx5w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (storybook 10.2.10, 9.1.19, 8.6.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm storybook

    Affected
    >= 8.1.0, < 8.6.17>= 8.7.0-alpha.0, < 9.1.19>= 10.0.0-beta.0, < 10.2.10
    Fixed in
    10.2.10, 9.1.19, 8.6.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-27148: 0.63% estimated exploitation activity in the next 30 days; percentile 50.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The WebSocket functionality in Storybook's dev server, used to create and update stories, is vulnerable to WebSocket hijacking. This vulnerability only affects the Storybook dev server; production builds are not impacted. Details Exploitation requires a developer to visit a malicious website while their local Storybook dev server is running. Because the WebSocket connection does not validate the origin of incoming connections, a malicious site can silently send WebSocket messages to the local instance without any further user interaction. If a Storybook dev server is intentionally exposed publicly (e.g. for design reviews or stakeholder demos) the risk is higher, as no malicious site visit is required. Any unauthenticated attacker can send WebSocket messages to it directly. The vulnerability affects the WebSocket message handlers for creating and saving stories, which can be exploited via unauthorized WebSocket connections to achieve persistent XSS or Remote Code Execution…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mjf5-7g4m-gx5w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mjf5-7g4m-gx5w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27148

Advisory: Storybook Dev Server is Vulnerable to WebSocket Hijacking
IDs: CVE-2026-27148, GHSA-mjf5-7g4m-gx5w
Record: https://patchnext.com/advisories/cve-2026-27148 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: storybook 10.2.10, 9.1.19, 8.6.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm storybook: affected >= 8.1.0, < 8.6.17; >= 8.7.0-alpha.0, < 9.1.19; >= 10.0.0-beta.0, < 10.2.10; fixed in 10.2.10, 9.1.19, 8.6.17

## Suggested inspection (read-only)
- `npm ls storybook --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on storybook.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mjf5-7g4m-gx5w (OSV record GHSA-mjf5-7g4m-gx5w lists affected ranges: npm storybook >=8.1.0 =8.7.0-alpha.0 =10.0.0-beta.0 <10.2.10 (fixed))
- Verified: https://github.com/advisories/GHSA-mjf5-7g4m-gx5w (GitHub-reviewed advisory GHSA-mjf5-7g4m-gx5w lists affected ranges: npm storybook >=8.1.0 =8.7.0-alpha.0 =10.0.0-beta.0 <10.2.10)

Commands are suggestions: review each one before running it.

Loading voting…