Craft CMS Race condition in Token Service potentially allows for token usage greater than the token limit
CVE-2026-27128GHSA-6fx5-5cw5-4897
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.8.23, 4.16.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 4.5.0-RC1, <= 4.16.18>= 5.0.0-RC1, <= 5.8.22
- Fixed in
- 5.8.23, 4.16.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6fx5-5cw5-4897 lists affected ranges: Packagist craftcms/cms >=4.5.0-RC1 =5.0.0-RC1 <=5.8.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-27128: 0.20% estimated exploitation activity in the next 30 days; percentile 9.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Time-of-Check-Time-of-Use (TOCTOU) race condition exists in Craft CMS’s token validation service for tokens that explicitly set a limited usage. The getTokenRoute() method reads a token’s usage count, checks if it’s within limits, then updates the database in separate non-atomic operations. By sending concurrent requests, an attacker can use a single-use impersonation token multiple times before the database update completes. To make this work, an attacker needs to obtain a valid user account impersonation URL with a non-expired token via some other means and exploit a race condition while bypassing any rate-limiting rules in place. For this to be a privilege escalation, the impersonation URL must include a token for a user account with more permissions than the current user. References https://github.com/craftcms/cms/commit/3e4afe18279951c024c64896aa2b93cda6d95fdf
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6fx5-5cw5-4897
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27128 Advisory: Craft CMS Race condition in Token Service potentially allows for token usage greater than the token limit IDs: CVE-2026-27128, GHSA-6fx5-5cw5-4897 Record: https://patchnext.com/advisories/cve-2026-27128 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.8.23, 4.16.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 4.5.0-RC1, <= 4.16.18; >= 5.0.0-RC1, <= 5.8.22; fixed in 5.8.23, 4.16.19 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6fx5-5cw5-4897 (GitHub-reviewed advisory GHSA-6fx5-5cw5-4897 lists affected ranges: Packagist craftcms/cms >=4.5.0-RC1 =5.0.0-RC1 <=5.8.22) Commands are suggestions: review each one before running it.
Loading voting…