Skip to content

← Actionable
Medium, CVSS 6.5amended

RediSearch Query Injection in @langchain/langgraph-checkpoint-redis

CVE-2026-27022GHSA-5mx2-w598-339m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@langchain/langgraph-checkpoint-redis 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-27022: 4.01% estimated exploitation activity in the next 30 days; percentile 90.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A query injection vulnerability exists in the @langchain/langgraph-checkpoint-redis package's filter handling. The RedisSaver and ShallowRedisSaver classes construct RediSearch queries by directly interpolating user-provided filter keys and values without proper escaping. RediSearch has special syntax characters that can modify query behavior, and when user-controlled data contains these characters, the query logic can be manipulated to bypass intended access controls. Attack surface The core vulnerability was in the list() methods of both RedisSaver and ShallowRedisSaver: these methods failed to escape RediSearch special characters in filter keys and values when constructing queries. When unescaped data containing RediSearch syntax was used, the injected operators were interpreted by RediSearch rather than treated as literal search values. This escaping bug enabled the following attack vector: - Thread boundary escape via OR operator: RediSearch uses | as an OR operator with…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5mx2-w598-339m

  2. Revision 1 · created ·

    Published from osv record GHSA-5mx2-w598-339m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27022

Advisory: RediSearch Query Injection in @langchain/langgraph-checkpoint-redis
IDs: CVE-2026-27022, GHSA-5mx2-w598-339m
Record: https://patchnext.com/advisories/cve-2026-27022 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @langchain/langgraph-checkpoint-redis 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @langchain/langgraph-checkpoint-redis: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls @langchain/langgraph-checkpoint-redis --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @langchain/langgraph-checkpoint-redis.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5mx2-w598-339m (OSV record GHSA-5mx2-w598-339m lists affected ranges: npm @langchain/langgraph-checkpoint-redis >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-5mx2-w598-339m (GitHub-reviewed advisory GHSA-5mx2-w598-339m lists affected ranges: npm @langchain/langgraph-checkpoint-redis >=0 <1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…