LibreNMS has a Stored XSS in Custom OID - unit parameter missing strip_tags()
CVE-2026-27016GHSA-fqx6-693c-f55g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 26.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- >= 24.10.0, < 26.2.0
- Fixed in
- 26.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fqx6-693c-f55g lists affected ranges: Packagist librenms/librenms >=24.10.0 <26.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-27016: 0.26% estimated exploitation activity in the next 30 days; percentile 18.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The unit parameter in Custom OID functionality lacks striptags() sanitization while other fields (name, oid, datatype) are sanitized. The unsanitized value is stored in the database and rendered without HTML escaping, allowing Stored XSS. Details Vulnerable Input Processing (includes/html/forms/customoid.inc.php lines 18-21): Vulnerable Output (graphs/customoid.inc.php lines 13-20): PoC Expected Output Impact - Attack Vector: User with device edit permissions sets malicious Unit value - Exploitation: XSS payload stored in database, executes for all users viewing device graphs - Consequences: - Session hijacking via cookie theft - Admin account takeover - Malicious actions on behalf of victims - Persistent attack affecting all users - Affected Users: All LibreNMS installations with Custom OID feature
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fqx6-693c-f55g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27016 Advisory: LibreNMS has a Stored XSS in Custom OID - unit parameter missing strip_tags() IDs: CVE-2026-27016, GHSA-fqx6-693c-f55g Record: https://patchnext.com/advisories/cve-2026-27016 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 26.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected >= 24.10.0, < 26.2.0; fixed in 26.2.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fqx6-693c-f55g (GitHub-reviewed advisory GHSA-fqx6-693c-f55g lists affected ranges: Packagist librenms/librenms >=24.10.0 <26.2.0) Commands are suggestions: review each one before running it.
Loading voting…