OpenClaw affected by Stored XSS in Control UI via unsanitized assistant name/avatar in inline script injection
CVE-2026-27009GHSA-37gc-85xm-2ww6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.15
- Fixed in
- 2026.2.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-37gc-85xm-2ww6 lists affected ranges: npm openclaw >=0 <2026.2.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-37gc-85xm-2ww6 lists affected ranges: npm openclaw >=0 <2026.2.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-27009: 0.26% estimated exploitation activity in the next 30 days; percentile 18.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Stored XSS in the OpenClaw Control UI when rendering assistant identity (name/avatar) into an inline <script tag without script-context-safe escaping. A crafted value containing </script could break out of the script tag and execute attacker-controlled JavaScript in the Control UI origin. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.14 - Fixed in: = 2026.2.15 (next release; fix is already merged on main) Details The gateway Control UI HTML response previously injected assistantName and assistantAvatar directly into an inline <script block using JSON.stringify(...). JSON.stringify does not prevent </script from terminating the script element, enabling stored XSS if an operator/admin sets the assistant identity to a malicious string. OpenClaw’s Control UI is intended for local use only (see SECURITY.md); this advisory’s CVSS reflects a loopback-only/local-access deployment assumption. Impact An attacker with the ability to set assistant…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-37gc-85xm-2ww6
- Revision 1 · created ·
Published from osv record GHSA-37gc-85xm-2ww6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27009 Advisory: OpenClaw affected by Stored XSS in Control UI via unsanitized assistant name/avatar in inline script injection IDs: CVE-2026-27009, GHSA-37gc-85xm-2ww6 Record: https://patchnext.com/advisories/cve-2026-27009 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.15; fixed in 2026.2.15 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-37gc-85xm-2ww6 (OSV record GHSA-37gc-85xm-2ww6 lists affected ranges: npm openclaw >=0 <2026.2.15 (fixed)) - Verified: https://github.com/advisories/GHSA-37gc-85xm-2ww6 (GitHub-reviewed advisory GHSA-37gc-85xm-2ww6 lists affected ranges: npm openclaw >=0 <2026.2.15) Commands are suggestions: review each one before running it.
Loading voting…