Skip to content

← Actionable
Medium, CVSS 6.8amended

OpenClaw hardened the skill download target directory validation

CVE-2026-27008GHSA-h7f7-89mm-pqh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.15
    Fixed in
    2026.2.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27008: 0.19% estimated exploitation activity in the next 30 days; percentile 8.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.14 - Fixed in: planned release 2026.2.15 Impact A bug in download skill installation allowed targetDir values from skill frontmatter to resolve outside the per-skill tools directory if not strictly validated. In the admin-only skills.install flow, this could write files outside the intended install sandbox. Fix Commit(s) - 2363e1b08 fix(security): restrict skill download target paths - b6305e972 test(skills): split installer security coverage Acknowledgement Thanks @Adam55A-code for reporting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h7f7-89mm-pqh6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h7f7-89mm-pqh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27008

Advisory: OpenClaw hardened the skill download target directory validation
IDs: CVE-2026-27008, GHSA-h7f7-89mm-pqh6
Record: https://patchnext.com/advisories/cve-2026-27008 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.15; fixed in 2026.2.15

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h7f7-89mm-pqh6 (OSV record GHSA-h7f7-89mm-pqh6 lists affected ranges: npm openclaw >=0 <2026.2.15 (fixed))
- Verified: https://github.com/advisories/GHSA-h7f7-89mm-pqh6 (GitHub-reviewed advisory GHSA-h7f7-89mm-pqh6 lists affected ranges: npm openclaw >=0 <2026.2.15)

Commands are suggestions: review each one before running it.

Loading voting…