Skip to content

← Actionable
Medium, CVSS 6.9amended

OpenClaw session tool visibility hardening and Telegram webhook secret fallback

CVE-2026-27004GHSA-6hf3-mhgc-cm65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.15
    Fixed in
    2026.2.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27004: 0.12% estimated exploitation activity in the next 30 days; percentile 1.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability In some shared-agent deployments, OpenClaw session tools (sessionslist, sessionshistory, sessionssend) allowed broader session targeting than some operators intended. This is primarily a configuration/visibility-scoping issue in multi-user environments where peers are not equally trusted. In Telegram webhook mode, monitor startup also did not fall back to per-account webhookSecret when only the account-level secret was configured. Typical Use Case Context Most regular OpenClaw deployments run a single agent, or run in trusted environments. In those setups, practical risk from this issue is generally low. Impact - Shared-agent, multi-user, less-trusted environments: session-tool access could expose transcript content across peer sessions. - Single-agent or trusted environments: practical impact is limited. - Telegram webhook mode: account-level secret wiring could be missed unless an explicit monitor webhook secret override was provided. Affected Packages / Versions -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6hf3-mhgc-cm65

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6hf3-mhgc-cm65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27004

Advisory: OpenClaw session tool visibility hardening and Telegram webhook secret fallback
IDs: CVE-2026-27004, GHSA-6hf3-mhgc-cm65
Record: https://patchnext.com/advisories/cve-2026-27004 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.15; fixed in 2026.2.15

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6hf3-mhgc-cm65 (OSV record GHSA-6hf3-mhgc-cm65 lists affected ranges: npm openclaw >=0 <2026.2.15 (fixed))
- Verified: https://github.com/advisories/GHSA-6hf3-mhgc-cm65 (GitHub-reviewed advisory GHSA-6hf3-mhgc-cm65 lists affected ranges: npm openclaw >=0 <2026.2.15)

Commands are suggestions: review each one before running it.

Loading voting…