Skip to content

← Actionable
High, CVSS 8.6amended

OpenClaw: Unsanitized CWD path injection into LLM prompts

CVE-2026-27001GHSA-2qj5-gwg2-xwc4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.15
    Fixed in
    2026.2.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27001: 0.23% estimated exploitation activity in the next 30 days; percentile 13.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview OpenClaw embedded the current working directory (workspace path) into the agent system prompt without sanitization. If an attacker can cause OpenClaw to run inside a directory whose name contains control/format characters (for example newlines or Unicode bidi/zero-width markers), those characters could break the prompt structure and inject attacker-controlled instructions. Impact Prompt injection may alter agent behavior and could lead to unintended tool use or disclosure of sensitive information. Affected Packages / Versions - Package: openclaw (npm) - Vulnerable versions: < 2026.2.15 (latest published vulnerable version as of 2026-02-16: 2026.2.14) - Patched versions: = 2026.2.15 Fix The workspace path is now sanitized before it is embedded into any LLM prompt output, stripping Unicode control/format characters and explicit line/paragraph separators. Workspace path resolution also applies the same sanitization as defense-in-depth. Fix Commit(s) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2qj5-gwg2-xwc4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2qj5-gwg2-xwc4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27001

Advisory: OpenClaw: Unsanitized CWD path injection into LLM prompts
IDs: CVE-2026-27001, GHSA-2qj5-gwg2-xwc4
Record: https://patchnext.com/advisories/cve-2026-27001 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.15; fixed in 2026.2.15

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2qj5-gwg2-xwc4 (OSV record GHSA-2qj5-gwg2-xwc4 lists affected ranges: npm openclaw >=0 <2026.2.15 (fixed))
- Verified: https://github.com/advisories/GHSA-2qj5-gwg2-xwc4 (GitHub-reviewed advisory GHSA-2qj5-gwg2-xwc4 lists affected ranges: npm openclaw >=0 <2026.2.15)

Commands are suggestions: review each one before running it.

Loading voting…