Skip to content

← Actionable
Unrated

LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream.

CVE-2026-26988GHSA-h3rv-q4rq-pqcv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 26.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-26988: 8.43% estimated exploitation activity in the next 30 days; percentile 95.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary SQL Injection in IPv6 Address Search functionality via address parameter A SQL injection vulnerability exists in the ajaxtable.php endpoint. The application fails to properly sanitize or parameterize user input when processing IPv6 address searches. Specifically, the address parameter is split into an address and a prefix, and the prefix portion is directly concatenated into the SQL query string without validation. This allows an attacker to inject arbitrary SQL commands, potentially leading to unauthorized data access or database manipulation. Details The vulnerability is located in the logic that handles address searching when searchtype is set to ipv6. The application takes the user-supplied address parameter and splits it using the / delimiter: If the searchtype is ipv6 and the $prefix variable is not empty, the code constructs the SQL query by directly concatenating the $prefix variable into the string: Unlike the ipv4 block, which attempts to use prepared statements…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h3rv-q4rq-pqcv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26988

Advisory: LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream.
IDs: CVE-2026-26988, GHSA-h3rv-q4rq-pqcv
Record: https://patchnext.com/advisories/cve-2026-26988 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 26.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected < 26.2.0; fixed in 26.2.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h3rv-q4rq-pqcv (GitHub-reviewed advisory GHSA-h3rv-q4rq-pqcv lists affected ranges: Packagist librenms/librenms >=0 <26.2.0)

Commands are suggestions: review each one before running it.

Loading voting…