OpenEXR has heap-buffer-overflow via signed integer underflow in ImfContextInit.cpp
CVE-2026-26981GHSA-q6vj-wxvf-5m8c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.4.5, 3.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openexr
- Affected
- >= 3.3.0, < 3.3.7>= 3.4.0, < 3.4.5
- Fixed in
- 3.3.7, 3.4.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q6vj-wxvf-5m8c lists affected ranges: PyPI openexr >=3.3.0 =3.4.0 <3.4.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6vj-wxvf-5m8c lists affected ranges: PyPI openexr >=3.3.0 =3.4.0 <3.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-26981: 0.60% estimated exploitation activity in the next 30 days; percentile 48.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A heap-buffer-overflow (OOB read) occurs in the istreamnonparallelread function in ImfContextInit.cpp when parsing a malformed EXR file through a memory-mapped IStream. A signed integer subtraction produces a negative value that is implicitly converted to sizet, resulting in a massive length being passed to memcpy. Affected Version - OpenEXR main branch (commit at time of testing) - src/lib/OpenEXR/ImfContextInit.cpp, lines 121–136 Root Cause ImfContextInit.cpp:121-126: sz is of type sizet (unsigned), but streamsz - nend yields a negative int64t value. This negative value is implicitly converted to sizet, wrapping around to a value close to 2^64, which is then passed to memcpy causing a heap-buffer-overflow. Suggested fix: sz = streamsz - nend → sz = streamsz - nread Reproduce Build OpenEXR as static libraries with ASAN enabled, then compile the PoC below. PoC Code: PoC Input: https://drive.google.com/file/d/1VhjdK11LA0LHdW1mJJIQEo64mc5tpOUV/view?usp=drivelink ASAN Log Impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q6vj-wxvf-5m8c
- Revision 1 · created ·
Published from osv record GHSA-q6vj-wxvf-5m8c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26981 Advisory: OpenEXR has heap-buffer-overflow via signed integer underflow in ImfContextInit.cpp IDs: CVE-2026-26981, GHSA-q6vj-wxvf-5m8c Record: https://patchnext.com/advisories/cve-2026-26981 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openexr 3.4.5, 3.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openexr: affected >= 3.3.0, < 3.3.7; >= 3.4.0, < 3.4.5; fixed in 3.3.7, 3.4.5 ## Suggested inspection (read-only) - `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openexr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q6vj-wxvf-5m8c (OSV record GHSA-q6vj-wxvf-5m8c lists affected ranges: PyPI openexr >=3.3.0 =3.4.0 <3.4.5 (fixed)) - Verified: https://github.com/advisories/GHSA-q6vj-wxvf-5m8c (GitHub-reviewed advisory GHSA-q6vj-wxvf-5m8c lists affected ranges: PyPI openexr >=3.3.0 =3.4.0 <3.4.5) Commands are suggestions: review each one before running it.
Loading voting…