Skip to content

← Actionable
Critical, CVSS 9.4amended

Ghost has a SQL injection in Content API

CVE-2026-26980GHSA-w52v-v783-gw97

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 6.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    >= 3.24.0, < 6.19.1
    Fixed in
    6.19.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-26980: 71.09% estimated exploitation activity in the next 30 days; percentile 99.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A SQL injection vulnerability existed in Ghost's Content API that allowed unauthenticated attackers to read arbitrary data from the database. Vulnerable Versions This vulnerability is present in Ghost v3.24.0 to v6.19.0. Patches v6.19.1 contains a fix for this issue. Note: as this vulnerability lets an attacker gain access to a site's API keys, we recommend reviewing staff users and rotating keys. We generally recommend always updating Ghost to its most current version. Workarounds There is no application-level workaround. The Content API key is public by design, so restricting key access does not mitigate this vulnerability. As a temporary mitigation, a reverse proxy or WAF rule can be used to block Content API requests containing slug%3A%5B or slug: in the query string filter parameter. Note that this may break legitimate slug filter functionality. References We thank Nicholas Carlini using Claude, Anthropic for disclosing this vulnerability responsibly. For more information…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w52v-v783-gw97

  2. Revision 2 · amended ·

    Amended from osv record GHSA-w52v-v783-gw97

  3. Revision 1 · created ·

    Published from ghsa record GHSA-w52v-v783-gw97

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26980

Advisory: Ghost has a SQL injection in Content API
IDs: CVE-2026-26980, GHSA-w52v-v783-gw97
Record: https://patchnext.com/advisories/cve-2026-26980 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 6.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected >= 3.24.0, < 6.19.1; fixed in 6.19.1

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w52v-v783-gw97 (GitHub-reviewed advisory GHSA-w52v-v783-gw97 lists affected ranges: npm ghost >=3.24.0 <6.19.1)
- Verified: https://osv.dev/vulnerability/GHSA-w52v-v783-gw97 (OSV record GHSA-w52v-v783-gw97 lists affected ranges: npm ghost >=3.24.0 <6.19.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…