Improper Control of Generation of Code ('Code Injection') in @tygo-van-den-hurk/slyde
CVE-2026-26974GHSA-w7h5-55jg-cq2f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tygo-van-den-hurk/slyde 0.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.0.5
- Fixed in
- 0.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w7h5-55jg-cq2f lists affected ranges: npm @tygo-van-den-hurk/slyde >=0 <0.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7h5-55jg-cq2f lists affected ranges: npm @tygo-van-den-hurk/slyde >=0 <0.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-26974: 0.61% estimated exploitation activity in the next 30 days; percentile 49.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This is a remote code execution (RCE) vulnerability. Node.js automatically imports /.plugin.{js,mjs} files including those from nodemodules, so any malicious package with a .plugin.js file could execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. Patches The issue has been patched in v0.0.5. Users should upgrade to v0.0.5 or later to mitigate the vulnerability. Workarounds - Audit and restrict which packages are installed in nodemodules. References - CWE-94: Improper Control of Generation of Code - GitHub Security Advisories documentation: https://docs.github.com/en/code-security/security-advisories
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w7h5-55jg-cq2f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w7h5-55jg-cq2f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26974
Advisory: Improper Control of Generation of Code ('Code Injection') in @tygo-van-den-hurk/slyde
IDs: CVE-2026-26974, GHSA-w7h5-55jg-cq2f
Record: https://patchnext.com/advisories/cve-2026-26974 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @tygo-van-den-hurk/slyde 0.0.5. A vendor fix does not mean a deployment is fixed.
## Affected components
- npm @tygo-van-den-hurk/slyde: affected < 0.0.5; fixed in 0.0.5
## Suggested inspection (read-only)
- `npm ls @tygo-van-den-hurk/slyde --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @tygo-van-den-hurk/slyde.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w7h5-55jg-cq2f (OSV record GHSA-w7h5-55jg-cq2f lists affected ranges: npm @tygo-van-den-hurk/slyde >=0 <0.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-w7h5-55jg-cq2f (GitHub-reviewed advisory GHSA-w7h5-55jg-cq2f lists affected ranges: npm @tygo-van-den-hurk/slyde >=0 <0.0.5)
Commands are suggestions: review each one before running it.Loading voting…