Skip to content

← Actionable
Critical, CVSS 9.8amended

VM2 Has a WASM Sandbox Escape

CVE-2026-26956GHSA-ffh4-j6h5-pg66

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.10.4
    Fixed in
    3.10.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-26956: 1.09% estimated exploitation activity in the next 30 days; percentile 65.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Full sandbox escape with arbitrary code execution. Attacker code inside VM.run() obtains host process object and runs host commands with zero host cooperation. Details Confirmed on: vm2 3.10.4, Node.js v25.6.1 (x64 Linux) Trigger: Attacker-controlled code passed to VM.run() Requires: Node.js version with WebAssembly exception handling + JSTag support (tested on v25.6.1) vm2's sandbox security relies on two JavaScript-level mechanisms: (1) a code transformer that injects handleException() into JS catch clauses to wrap host-realm errors, and (2) bridge Proxies that wrap cross-context objects. Both operate entirely within JavaScript. WebAssembly's trytable instruction with a JSTag catch handler catches JavaScript exceptions at V8's C++ level — below JavaScript entirely. When an imported JS function throws a TypeError produced by Symbol-to-string coercion during stack formatting (e.name = Symbol(); e.stack), the WASM trytable catches it as an opaque externref and returns it as a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ffh4-j6h5-pg66

  2. Revision 2 · amended ·

    Amended from osv record GHSA-ffh4-j6h5-pg66

  3. Revision 1 · created ·

    Published from ghsa record GHSA-ffh4-j6h5-pg66

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26956

Advisory: VM2 Has a WASM Sandbox Escape
IDs: CVE-2026-26956, GHSA-ffh4-j6h5-pg66
Record: https://patchnext.com/advisories/cve-2026-26956 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.10.4; fixed in 3.10.5

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ffh4-j6h5-pg66 (GitHub-reviewed advisory GHSA-ffh4-j6h5-pg66 lists affected ranges: npm vm2 >=0 <=3.10.4)
- Verified: https://osv.dev/vulnerability/GHSA-ffh4-j6h5-pg66 (OSV record GHSA-ffh4-j6h5-pg66 lists affected ranges: npm vm2 >=0 <3.10.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…