CleverTap Web SDK is vulnerable to DOM-based Cross-Site Scripting (XSS) via window.postMessage
CVE-2026-26862GHSA-jfrq-hj9f-c8qx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (clevertap-web-sdk 1.15.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.15.3
- Fixed in
- 1.15.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfrq-hj9f-c8qx lists affected ranges: npm clevertap-web-sdk >=0 <1.15.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfrq-hj9f-c8qx lists affected ranges: npm clevertap-web-sdk >=0 <1.15.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-26862: 0.42% estimated exploitation activity in the next 30 days; percentile 36.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CleverTap Web SDK version 1.15.2 and earlier is vulnerable to DOM-based Cross-Site Scripting (XSS) via window.postMessage in the Visual Builder module. The origin validation in src/modules/visualBuilder/pageBuilder.js (lines 56-60) uses the includes() method to verify the originUrl contains "dashboard.clevertap.com", which can be bypassed by an attacker using a crafted subdomain.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jfrq-hj9f-c8qx
- Revision 1 · created ·
Published from osv record GHSA-jfrq-hj9f-c8qx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26862 Advisory: CleverTap Web SDK is vulnerable to DOM-based Cross-Site Scripting (XSS) via window.postMessage IDs: CVE-2026-26862, GHSA-jfrq-hj9f-c8qx Record: https://patchnext.com/advisories/cve-2026-26862 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: clevertap-web-sdk 1.15.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm clevertap-web-sdk: affected < 1.15.3; fixed in 1.15.3 ## Suggested inspection (read-only) - `npm ls clevertap-web-sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on clevertap-web-sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jfrq-hj9f-c8qx (OSV record GHSA-jfrq-hj9f-c8qx lists affected ranges: npm clevertap-web-sdk >=0 <1.15.3 (fixed)) - Verified: https://github.com/advisories/GHSA-jfrq-hj9f-c8qx (GitHub-reviewed advisory GHSA-jfrq-hj9f-c8qx lists affected ranges: npm clevertap-web-sdk >=0 <1.15.3) Commands are suggestions: review each one before running it.
Loading voting…