OpenClaw iMessage group allowlist authorization inherited DM pairing-store identities
CVE-2026-26328GHSA-g34w-4xqq-h79m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14; clawdbot 2026.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g34w-4xqq-h79m lists affected ranges: npm openclaw >=0 =0 <2026.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g34w-4xqq-h79m lists affected ranges: npm openclaw >=0 =0 <2026.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-26328: 0.32% estimated exploitation activity in the next 30 days; percentile 24.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Under iMessage groupPolicy=allowlist, group authorization could be satisfied by sender identities coming from the DM pairing store, broadening DM trust into group contexts. Details Affected component: src/imessage/monitor/monitor-provider.ts. Vulnerable logic derived effectiveGroupAllowFrom using both the static group allowlist and DM pairing-store identities (storeAllowFrom). This allowed a sender approved via DM pairing to satisfy group authorization in groups even if the sender/chat was not explicitly present in groupAllowFrom. This weakens boundary separation between DM pairing and group allowlist authorization. Affected Packages / Versions - openclaw (npm): affected <= 2026.2.13 - clawdbot (npm): affected <= 2026.1.24-3 Fix Commit(s) - openclaw/openclaw@872079d42fe105ece2900a1dd6ab321b92da2d59 - openclaw/openclaw@90d1e9cd71419168b2faa54a759b124a3eacfae7 Thanks @vincentkoc for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g34w-4xqq-h79m
- Revision 1 · created ·
Published from osv record GHSA-g34w-4xqq-h79m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26328 Advisory: OpenClaw iMessage group allowlist authorization inherited DM pairing-store identities IDs: CVE-2026-26328, GHSA-g34w-4xqq-h79m Record: https://patchnext.com/advisories/cve-2026-26328 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14; clawdbot 2026.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.14; fixed in 2026.2.14 - npm clawdbot: affected < 2026.2.14; fixed in 2026.2.14 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw, clawdbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g34w-4xqq-h79m (OSV record GHSA-g34w-4xqq-h79m lists affected ranges: npm openclaw >=0 =0 <2026.2.14 (fixed)) - Verified: https://github.com/advisories/GHSA-g34w-4xqq-h79m (GitHub-reviewed advisory GHSA-g34w-4xqq-h79m lists affected ranges: npm openclaw >=0 =0 <2026.2.14) Commands are suggestions: review each one before running it.
Loading voting…