OpenClaw skills.status could leak secrets to operator.read clients
CVE-2026-26326GHSA-8mh7-phf8-xgfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.14
- Fixed in
- 2026.2.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8mh7-phf8-xgfm lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8mh7-phf8-xgfm lists affected ranges: npm openclaw >=0 <2026.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-26326: 0.34% estimated exploitation activity in the next 30 days; percentile 27.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary skills.status could disclose secrets to operator.read clients by returning raw resolved config values in configChecks for skill requires.config paths. Affected Packages / Versions - Package: openclaw (npm) - Affected: <= 2026.2.13 - Patched: 2026.2.14 Details The gateway method skills.status returned a requirements report that included configChecks[].value (the resolved value for each requires.config entry). If a skill required a broad config subtree (for example channels.discord), the report could include secrets such as Discord bot tokens. skills.status is callable with operator.read, so read-scoped clients could obtain secrets without operator.admin / config. access. Fix - Stop including raw resolved config values in requirement checks (return only { path, satisfied }). - Narrow the Discord skill requirement to the token key. Fix commit(s): - d3428053d95eefbe10ecf04f92218ffcba55ae5a - ebc68861a61067fc37f9298bded3eec9de0ba783 Mitigation Rotate any Discord tokens that may…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8mh7-phf8-xgfm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8mh7-phf8-xgfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26326 Advisory: OpenClaw skills.status could leak secrets to operator.read clients IDs: CVE-2026-26326, GHSA-8mh7-phf8-xgfm Record: https://patchnext.com/advisories/cve-2026-26326 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.14; fixed in 2026.2.14 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8mh7-phf8-xgfm (OSV record GHSA-8mh7-phf8-xgfm lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)) - Verified: https://github.com/advisories/GHSA-8mh7-phf8-xgfm (GitHub-reviewed advisory GHSA-8mh7-phf8-xgfm lists affected ranges: npm openclaw >=0 <2026.2.14) Commands are suggestions: review each one before running it.
Loading voting…