OpenClaw is Missing Webhook Authentication in Telnyx Provider Allows Unauthenticated Requests
CVE-2026-26319GHSA-4hg8-92x6-h2f3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.14
- Fixed in
- 2026.2.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4hg8-92x6-h2f3 lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4hg8-92x6-h2f3 lists affected ranges: npm openclaw >=0 <2026.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-26319: 0.32% estimated exploitation activity in the next 30 days; percentile 25.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In affected versions, OpenClaw's optional @openclaw/voice-call plugin Telnyx webhook handler could accept unsigned inbound webhook requests when telnyx.publicKey was not configured, allowing unauthenticated callers to forge Telnyx events. This only impacts deployments where the Voice Call plugin is installed, enabled, and the webhook endpoint is reachable from the attacker (for example, publicly exposed via a tunnel/proxy). Affected Packages / Versions - Package: openclaw (npm) - Affected: <= 2026.2.13 - Fixed: = 2026.2.14 (planned) Details Telnyx webhooks are expected to be authenticated via Ed25519 signature verification. In affected versions, TelnyxProvider.verifyWebhook() could effectively fail open when no Telnyx public key was configured, allowing arbitrary HTTP POST requests to the voice-call webhook endpoint to be treated as legitimate Telnyx events. Fix The fix makes Telnyx webhook verification fail closed by default and requires telnyx.publicKey (or TELNYXPUBLICKEY)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4hg8-92x6-h2f3
- Revision 1 · created ·
Published from osv record GHSA-4hg8-92x6-h2f3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26319 Advisory: OpenClaw is Missing Webhook Authentication in Telnyx Provider Allows Unauthenticated Requests IDs: CVE-2026-26319, GHSA-4hg8-92x6-h2f3 Record: https://patchnext.com/advisories/cve-2026-26319 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.14; fixed in 2026.2.14 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4hg8-92x6-h2f3 (OSV record GHSA-4hg8-92x6-h2f3 lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)) - Verified: https://github.com/advisories/GHSA-4hg8-92x6-h2f3 (GitHub-reviewed advisory GHSA-4hg8-92x6-h2f3 lists affected ranges: npm openclaw >=0 <2026.2.14) Commands are suggestions: review each one before running it.
Loading voting…