Command Injection via Unsanitized locate Output in versions() — systeminformation
CVE-2026-26318GHSA-5vv4-hvf7-2h46
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 5.31.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.31.0
- Fixed in
- 5.31.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5vv4-hvf7-2h46 lists affected ranges: npm systeminformation >=0 <5.31.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vv4-hvf7-2h46 lists affected ranges: npm systeminformation >=0 <5.31.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-26318: 1.28% estimated exploitation activity in the next 30 days; percentile 70.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Command Injection via Unsanitized locate Output in versions() — systeminformation Package: systeminformation (npm) Tested Version: 5.30.7 Affected Platform: Linux Author: Sebastian Hildebrandt Weekly Downloads: ~5,000,000+ Repository: https://github.com/sebhildebrandt/systeminformation Severity: Medium CWE: CWE-78 (OS Command Injection) --- The Vulnerable Code Path Inside the versions() function, when detecting the PostgreSQL version on Linux, the code does this: Here's what happens step by step: 1. It runs locate bin/postgres to search the filesystem for PostgreSQL binaries 2. It splits the output by newline and sorts the results alphabetically 3. It takes the last element (highest alphabetically) 4. It concatenates that path directly into a new exec() call with + ' -V' No sanitizeShellString(). No path validation. No execFile(). Raw string concatenation into exec(). The locate command reads from a system-wide database (plocate.db or mlocate.db) that indexes all filenames on the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5vv4-hvf7-2h46
- Revision 1 · created ·
Published from osv record GHSA-5vv4-hvf7-2h46
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26318 Advisory: Command Injection via Unsanitized `locate` Output in `versions()` — systeminformation IDs: CVE-2026-26318, GHSA-5vv4-hvf7-2h46 Record: https://patchnext.com/advisories/cve-2026-26318 (revision 2, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: systeminformation 5.31.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm systeminformation: affected < 5.31.0; fixed in 5.31.0 ## Suggested inspection (read-only) - `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on systeminformation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5vv4-hvf7-2h46 (OSV record GHSA-5vv4-hvf7-2h46 lists affected ranges: npm systeminformation >=0 <5.31.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5vv4-hvf7-2h46 (GitHub-reviewed advisory GHSA-5vv4-hvf7-2h46 lists affected ranges: npm systeminformation >=0 <5.31.0) Commands are suggestions: review each one before running it.
Loading voting…