Skip to content

← Actionable
High, CVSS 7.1amended

OpenClaw affected by cross-site request forgery (CSRF) through loopback browser mutation endpoints

CVE-2026-26317GHSA-3fqr-4cg8-h96q

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.14
    Fixed in
    2026.2.14
  • npm clawdbot

    Affected
    <= 2026.1.24-3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-26317: 0.16% estimated exploitation activity in the next 30 days; percentile 5.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Browser-facing localhost mutation routes accepted cross-origin browser requests without explicit Origin/Referer validation. Loopback binding reduces remote exposure but does not prevent browser-initiated requests from malicious origins. Impact A malicious website can trigger unauthorized state changes against a victim's local OpenClaw browser control plane (for example opening tabs, starting/stopping the browser, mutating storage/cookies) if the browser control service is reachable on loopback in the victim's browser context. Affected Packages / Versions - openclaw (npm): <= 2026.2.13 - clawdbot (npm): <= 2026.1.24-3 Details The browser control servers bind to loopback but exposed mutating HTTP endpoints without a CSRF-style guard. Browsers may send cross-origin requests to loopback addresses; without explicit validation, state-changing operations could be triggered from a non-loopback Origin/Referer. Fix Mutating HTTP methods (POST/PUT/PATCH/DELETE) are rejected when the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3fqr-4cg8-h96q

  2. Revision 1 · created ·

    Published from osv record GHSA-3fqr-4cg8-h96q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26317

Advisory: OpenClaw affected by cross-site request forgery (CSRF) through loopback browser mutation endpoints
IDs: CVE-2026-26317, GHSA-3fqr-4cg8-h96q
Record: https://patchnext.com/advisories/cve-2026-26317 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.14; fixed in 2026.2.14
- npm clawdbot: affected <= 2026.1.24-3

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls clawdbot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw, clawdbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3fqr-4cg8-h96q (OSV record GHSA-3fqr-4cg8-h96q lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)
- Verified: https://github.com/advisories/GHSA-3fqr-4cg8-h96q (GitHub-reviewed advisory GHSA-3fqr-4cg8-h96q lists affected ranges: npm openclaw >=0 =0 <=2026.1.24-3)

Commands are suggestions: review each one before running it.

Loading voting…