Skip to content

← Actionable
High, CVSS 7.5amended

OpenClaw BlueBubbles webhook auth bypass via loopback proxy trust

CVE-2026-26316GHSA-pchc-86f6-8758

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.13; @openclaw/bluebubbles 2026.2.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-26316: 0.36% estimated exploitation activity in the next 30 days; percentile 30.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions, the optional BlueBubbles iMessage channel plugin could accept webhook requests as authenticated based only on the TCP peer address being loopback (127.0.0.1, ::1, ::ffff:127.0.0.1) even when the configured webhook secret was missing or incorrect. This does not affect the default iMessage integration unless BlueBubbles is installed and enabled. Affected Packages / Versions - npm: openclaw < 2026.2.13 - npm: @openclaw/bluebubbles < 2026.2.13 Details If a deployment exposes the BlueBubbles webhook endpoint through a same-host reverse proxy (or an attacker can reach loopback via SSRF), an unauthenticated party may be able to inject inbound webhook events into the agent pipeline. Fix Commit(s) - f836c385ffc746cb954e8ee409f99d079bfdcd2f - 743f4b28495cdeb0d5bf76f6ebf4af01f6a02e5a (defense-in-depth) Mitigations - Set a non-empty BlueBubbles webhook password. - Avoid deployments where a public-facing reverse proxy forwards to a loopback-bound Gateway without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pchc-86f6-8758

  2. Revision 1 · created ·

    Published from osv record GHSA-pchc-86f6-8758

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26316

Advisory: OpenClaw BlueBubbles webhook auth bypass via loopback proxy trust
IDs: CVE-2026-26316, GHSA-pchc-86f6-8758
Record: https://patchnext.com/advisories/cve-2026-26316 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.13; @openclaw/bluebubbles 2026.2.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.13; fixed in 2026.2.13
- npm @openclaw/bluebubbles: affected < 2026.2.13; fixed in 2026.2.13

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openclaw/bluebubbles --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw, @openclaw/bluebubbles.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pchc-86f6-8758 (OSV record GHSA-pchc-86f6-8758 lists affected ranges: npm openclaw >=0 =0 <2026.2.13 (fixed))
- Verified: https://github.com/advisories/GHSA-pchc-86f6-8758 (GitHub-reviewed advisory GHSA-pchc-86f6-8758 lists affected ranges: npm openclaw >=0 =0 <2026.2.13)

Commands are suggestions: review each one before running it.

Loading voting…