Skip to content

← Actionable
High, CVSS 7.5

Envoy has RBAC Header Validation Bypass via Multi-Value Header Concatenation

CVE-2026-26308GHSA-ghc4-35x6-crw5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/envoyproxy/envoy 1.37.1, 1.36.5, 1.35.9, 1.34.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/envoyproxy/envoy

    Affected
    >= 1.37.0, <= 1.37.0>= 1.36.0, <= 1.36.4>= 1.35.0, <= 1.35.8<= 1.34.12
    Fixed in
    1.36.5, 1.37.1, 1.35.9, 1.34.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-26308: 0.30% estimated exploitation activity in the next 30 days; percentile 23.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

1. Summary The Envoy RBAC (Role-Based Access Control) filter contains a logic vulnerability in how it validates HTTP headers when multiple values are present for the same header name. Instead of validating each header value individually, Envoy concatenates all values into a single comma-separated string. This behavior allows attackers to bypass RBAC policies—specifically "Deny" rules—by sending duplicate headers, effectively obscuring the malicious value from exact-match mechanisms. 2. Attack Scenario Consider an environment where an administrator wants to block external access to internal resources using a specific header flag. Configuration The Envoy proxy is configured with a Deny rule to reject requests containing the header internal: true. Rule Type: Exact Match Target: internal header must not equal true. The Bypass Logic 1. Standard Request (Blocked): Input: internal: true Envoy Processing: Sees string "true". Result: Match found. Request Denied. 2. Exploit Request (Bypassed):…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ghc4-35x6-crw5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26308

Advisory: Envoy has RBAC Header Validation Bypass via Multi-Value Header Concatenation
IDs: CVE-2026-26308, GHSA-ghc4-35x6-crw5
Record: https://patchnext.com/advisories/cve-2026-26308 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/envoyproxy/envoy 1.37.1, 1.36.5, 1.35.9, 1.34.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/envoyproxy/envoy: affected >= 1.37.0, <= 1.37.0; >= 1.36.0, <= 1.36.4; >= 1.35.0, <= 1.35.8; <= 1.34.12; fixed in 1.36.5, 1.37.1, 1.35.9, 1.34.13

## Suggested inspection (read-only)
- Go github.com/envoyproxy/envoy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/envoyproxy/envoy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ghc4-35x6-crw5 (GitHub-reviewed advisory GHSA-ghc4-35x6-crw5 lists affected ranges: Go github.com/envoyproxy/envoy >=1.37.0 =1.36.0 =1.35.0 =0 <=1.34.12)

Commands are suggestions: review each one before running it.

Loading voting…