Systeminformation has a Command Injection via unsanitized interface parameter in wifi.js retry path
CVE-2026-26280GHSA-9c88-49p5-5ggf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 5.30.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.30.8
- Fixed in
- 5.30.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9c88-49p5-5ggf lists affected ranges: npm systeminformation >=0 <5.30.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9c88-49p5-5ggf lists affected ranges: npm systeminformation >=0 <5.30.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-26280: 1.37% estimated exploitation activity in the next 30 days; percentile 71.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A command injection vulnerability in the wifiNetworks() function allows an attacker to execute arbitrary OS commands via an unsanitized network interface parameter in the retry code path. Details In lib/wifi.js, the wifiNetworks() function sanitizes the iface parameter on the initial call (line 437). However, when the initial scan returns empty results, a setTimeout retry (lines 440-441) calls getWifiNetworkListIw(iface) with the original unsanitized iface value, which is passed directly to execSync('iwlist ${iface} scan'). PoC 1. Install systeminformation@5.30.7 2. Call si.wifiNetworks('eth0; id') 3. The first call sanitizes input, but if results are empty, the retry executes: iwlist eth0; id scan Impact Remote Code Execution (RCE). Any application passing user-controlled input to si.wifiNetworks() is vulnerable to arbitrary command execution with the privileges of the Node.js process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9c88-49p5-5ggf
- Revision 1 · created ·
Published from osv record GHSA-9c88-49p5-5ggf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26280 Advisory: Systeminformation has a Command Injection via unsanitized interface parameter in wifi.js retry path IDs: CVE-2026-26280, GHSA-9c88-49p5-5ggf Record: https://patchnext.com/advisories/cve-2026-26280 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: systeminformation 5.30.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm systeminformation: affected < 5.30.8; fixed in 5.30.8 ## Suggested inspection (read-only) - `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on systeminformation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9c88-49p5-5ggf (OSV record GHSA-9c88-49p5-5ggf lists affected ranges: npm systeminformation >=0 <5.30.8 (fixed)) - Verified: https://github.com/advisories/GHSA-9c88-49p5-5ggf (GitHub-reviewed advisory GHSA-9c88-49p5-5ggf lists affected ranges: npm systeminformation >=0 <5.30.8) Commands are suggestions: review each one before running it.
Loading voting…