Skip to content

← Actionable
High, CVSS 7.5amended

fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)

CVE-2026-26278GHSA-jmr7-xgp7-cmfj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 5.3.6, 4.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-xml-parser

    Affected
    >= 4.1.3, < 4.5.4>= 5.0.0, < 5.3.6
    Fixed in
    5.3.6, 4.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-26278: 0.94% estimated exploitation activity in the next 30 days; percentile 60.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The XML parser can be forced to do an unlimited amount of entity expansion. With a very small XML input, it’s possible to make the parser spend seconds or even minutes processing a single request, effectively freezing the application. Details There is a check in DocTypeReader.js that tries to prevent entity expansion attacks by rejecting entities that reference other entities (it looks for & inside entity values). This does stop classic “Billion Laughs” payloads. However, it doesn’t stop a much simpler variant. If you define one large entity that contains only raw text (no & characters) and then reference it many times, the parser will happily expand it every time. There is no limit on how large the expanded result can become, or how many replacements are allowed. The problem is in replaceEntitiesValue() inside OrderedObjParser.js. It repeatedly runs val.replace() in a loop, without any checks on total output size or execution cost. As the entity grows or the number of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jmr7-xgp7-cmfj

  2. Revision 1 · created ·

    Published from osv record GHSA-jmr7-xgp7-cmfj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26278

Advisory: fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)
IDs: CVE-2026-26278, GHSA-jmr7-xgp7-cmfj
Record: https://patchnext.com/advisories/cve-2026-26278 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 5.3.6, 4.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-xml-parser: affected >= 4.1.3, < 4.5.4; >= 5.0.0, < 5.3.6; fixed in 5.3.6, 4.5.4

## Suggested inspection (read-only)
- `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-xml-parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jmr7-xgp7-cmfj (OSV record GHSA-jmr7-xgp7-cmfj lists affected ranges: npm fast-xml-parser >=4.1.3 =5.0.0 <5.3.6 (fixed))
- Verified: https://github.com/advisories/GHSA-jmr7-xgp7-cmfj (GitHub-reviewed advisory GHSA-jmr7-xgp7-cmfj lists affected ranges: npm fast-xml-parser >=4.1.3 =5.0.0 <5.3.6)

Commands are suggestions: review each one before running it.

Loading voting…