Improper Digest Verification in httpsig-hyper May Allow Message Integrity Bypass
CVE-2026-26275GHSA-7v42-g35v-xrch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (httpsig-hyper 0.0.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io httpsig-hyper
- Affected
- < 0.0.23
- Fixed in
- 0.0.23
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7v42-g35v-xrch lists affected ranges: crates.io httpsig-hyper >=0 <0.0.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-26275: 0.18% estimated exploitation activity in the next 30 days; percentile 8.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An issue was discovered in httpsig-hyper where Digest header verification could incorrectly succeed due to misuse of Rust's matches! macro. Specifically, the comparison: treated expecteddigest as a pattern binding rather than a value comparison, resulting in unconditional success of the match expression. As a consequence, digest verification could incorrectly return success even when the computed digest did not match the expected value. Applications relying on Digest verification as part of HTTP message signature validation may therefore fail to detect message body modification. The severity depends on how the library is integrated and whether additional signature validation layers are enforced. --- Patches This issue has been fixed in: - httpsig-hyper = 0.0.23 The fix replaces the incorrect matches! usage with proper value comparison and additionally introduces constant-time comparison for digest verification as defense-in-depth. Regression tests have also been added to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7v42-g35v-xrch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26275 Advisory: Improper Digest Verification in httpsig-hyper May Allow Message Integrity Bypass IDs: CVE-2026-26275, GHSA-7v42-g35v-xrch Record: https://patchnext.com/advisories/cve-2026-26275 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: httpsig-hyper 0.0.23. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io httpsig-hyper: affected < 0.0.23; fixed in 0.0.23 ## Suggested inspection (read-only) - crates.io httpsig-hyper: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on httpsig-hyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7v42-g35v-xrch (GitHub-reviewed advisory GHSA-7v42-g35v-xrch lists affected ranges: crates.io httpsig-hyper >=0 <0.0.23) Commands are suggestions: review each one before running it.
Loading voting…