Skip to content

← Actionable
Medium, CVSS 6.6

October CMS has Safe Mode Bypass via Twig Database Write Operations

CVE-2026-26274GHSA-h6jm-f4hh-fw27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/october 4.1.10, 3.7.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/october

    Affected
    < 3.7.14>= 4.0.0, < 4.1.10
    Fixed in
    4.1.10, 3.7.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-26274: 0.23% estimated exploitation activity in the next 30 days; percentile 13.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was identified in the Twig sandbox security policy that allowed database write operations when cms.safemode is enabled. Backend users with Developer permissions could use Twig template markup to execute insert, update, and delete operations on any database table through the query builder, which is included in the sandbox allow-list. Impact - Arbitrary database writes including modification or deletion of any table - Requires authenticated backend access with Developer permissions - Only relevant when cms.safemode is enabled (otherwise direct PHP injection is already possible) Patches The vulnerability has been patched in v3.7.14 and v4.1.10. Write operations such as insert, update, delete, and truncate are now blocked on query builder and model objects within the Twig sandbox. All users are encouraged to upgrade to the latest patched version. Workarounds If upgrading immediately is not possible: - Restrict Developer tool access to fully trusted administrators only…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h6jm-f4hh-fw27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26274

Advisory: October CMS has Safe Mode Bypass via Twig Database Write Operations
IDs: CVE-2026-26274, GHSA-h6jm-f4hh-fw27
Record: https://patchnext.com/advisories/cve-2026-26274 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/october 4.1.10, 3.7.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/october: affected < 3.7.14; >= 4.0.0, < 4.1.10; fixed in 4.1.10, 3.7.14

## Suggested inspection (read-only)
- Packagist october/october: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/october.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h6jm-f4hh-fw27 (GitHub-reviewed advisory GHSA-h6jm-f4hh-fw27 lists affected ranges: Packagist october/october >=0 =4.0.0 <4.1.10)

Commands are suggestions: review each one before running it.

Loading voting…