Skip to content

← Actionable
Critical, CVSS 9.8

Known affected by Account Takeover via Password Reset Token Leakage

CVE-2026-26273GHSA-78wq-6gcv-w28r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (idno/known 1.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-26273: 0.97% estimated exploitation activity in the next 30 days; percentile 62.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Critical Broken Authentication vulnerability exists in Known 1.6.2. The application leaks the password reset token within a hidden HTML input field on the password reset page. This allows any unauthenticated attacker to retrieve the reset token for any user by simply querying the user's email, leading to full Account Takeover (ATO) without requiring access to the victim's email inbox. Details The vulnerability occurs within the password reset flow. When a reset is requested, the application generates a verification code. However, the subsequent reset page (/account/password/reset/) incorrectly reflects this code back to the client in the HTML source code. Specifically, the sensitive token is embedded in: <input type="hidden" name="code" value="[SECRETTOKEN]" Because this page is accessible via a GET request using the victim's email as a parameter, an attacker can programmatically extract the token. PoC 1. The attacker asks for a password reset for the victim <img…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-78wq-6gcv-w28r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26273

Advisory: Known affected by Account Takeover via Password Reset Token Leakage
IDs: CVE-2026-26273, GHSA-78wq-6gcv-w28r
Record: https://patchnext.com/advisories/cve-2026-26273 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: idno/known 1.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist idno/known: affected <= 1.6.2; fixed in 1.6.3

## Suggested inspection (read-only)
- Packagist idno/known: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on idno/known.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-78wq-6gcv-w28r (GitHub-reviewed advisory GHSA-78wq-6gcv-w28r lists affected ranges: Packagist idno/known >=0 <=1.6.2)

Commands are suggestions: review each one before running it.

Loading voting…