Skip to content

← Actionable
Critical, CVSS 9.2amended

Crawl4AI Has Local File Inclusion in Docker API via file:// URLs

CVE-2026-26217GHSA-vx9w-5cx4-9796

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (crawl4ai 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI crawl4ai

    Affected
    < 0.8.0
    Fixed in
    0.8.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-26217: 2.10% estimated exploitation activity in the next 30 days; percentile 81.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A local file inclusion vulnerability exists in the Crawl4AI Docker API. The /executejs, /screenshot, /pdf, and /html endpoints accept file:// URLs, allowing attackers to read arbitrary files from the server filesystem. Attack Vector: Impact An unauthenticated attacker can: - Read sensitive files (/etc/passwd, /etc/shadow, application configs) - Access environment variables via /proc/self/environ - Discover internal application structure - Potentially read credentials and API keys Workarounds 1. Disable the Docker API 2. Add authentication to the API 3. Use network-level filtering

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-vx9w-5cx4-9796

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-vx9w-5cx4-9796

  4. Revision 1 · created ·

    Published from ghsa record GHSA-vx9w-5cx4-9796

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26217

Advisory: Crawl4AI Has Local File Inclusion in Docker API via file:// URLs
IDs: CVE-2026-26217, GHSA-vx9w-5cx4-9796
Record: https://patchnext.com/advisories/cve-2026-26217 (revision 4, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: crawl4ai 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI crawl4ai: affected < 0.8.0; fixed in 0.8.0

## Suggested inspection (read-only)
- `python -m pip show crawl4ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on crawl4ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vx9w-5cx4-9796 (GitHub-reviewed advisory GHSA-vx9w-5cx4-9796 lists affected ranges: PyPI crawl4ai >=0 <0.8.0)
- Verified: https://osv.dev/vulnerability/GHSA-vx9w-5cx4-9796 (OSV record GHSA-vx9w-5cx4-9796 lists affected ranges: PyPI crawl4ai >=0 <0.8.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…