Crawl4AI is Vulnerable to Remote Code Execution in Docker API via Hooks Parameter
CVE-2026-26216GHSA-5882-5rx9-xgxp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (crawl4ai 0.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI crawl4ai
- Affected
- < 0.8.0
- Fixed in
- 0.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5882-5rx9-xgxp lists affected ranges: PyPI crawl4ai >=0 <0.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5882-5rx9-xgxp lists affected ranges: PyPI crawl4ai >=0 <0.8.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-26216: 6.42% estimated exploitation activity in the next 30 days; percentile 93.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A critical remote code execution vulnerability exists in the Crawl4AI Docker API deployment. The /crawl endpoint accepts a hooks parameter containing Python code that is executed using exec(). The import builtin was included in the allowed builtins, allowing attackers to import arbitrary modules and execute system commands. Attack Vector: Impact An unauthenticated attacker can: - Execute arbitrary system commands - Read/write files on the server - Exfiltrate sensitive data (environment variables, API keys) - Pivot to internal network services - Completely compromise the server Mitigation 1. Upgrade to v0.8.0 (recommended) 2. If unable to upgrade immediately: - Disable the Docker API - Block /crawl endpoint at network level - Add authentication to the API Fix Details 1. Removed import from allowedbuiltins in hookmanager.py 2. Hooks disabled by default (CRAWL4AIHOOKSENABLED=false) 3. Users must explicitly opt-in to enable hooks Credits Discovered by Neo by ProjectDiscovery…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-5882-5rx9-xgxp
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-5882-5rx9-xgxp
- Revision 1 · created ·
Published from ghsa record GHSA-5882-5rx9-xgxp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26216 Advisory: Crawl4AI is Vulnerable to Remote Code Execution in Docker API via Hooks Parameter IDs: CVE-2026-26216, GHSA-5882-5rx9-xgxp Record: https://patchnext.com/advisories/cve-2026-26216 (revision 4, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: crawl4ai 0.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI crawl4ai: affected < 0.8.0; fixed in 0.8.0 ## Suggested inspection (read-only) - `python -m pip show crawl4ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on crawl4ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5882-5rx9-xgxp (GitHub-reviewed advisory GHSA-5882-5rx9-xgxp lists affected ranges: PyPI crawl4ai >=0 <0.8.0) - Verified: https://osv.dev/vulnerability/GHSA-5882-5rx9-xgxp (OSV record GHSA-5882-5rx9-xgxp lists affected ranges: PyPI crawl4ai >=0 <0.8.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…