Skip to content

← Actionable
High, CVSS 7.5amended

cbor2 has a Denial of Service via Uncontrolled Recursion in cbor2.loads

CVE-2026-26209GHSA-3c37-wwvx-h642

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cbor2 5.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI cbor2

    Affected
    <= 5.8.0
    Fixed in
    5.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-26209: 0.40% estimated exploitation activity in the next 30 days; percentile 33.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary - The cbor2 library is vulnerable to a Denial of Service (DoS) attack caused by uncontrolled recursion when decoding deeply nested CBOR structures. - This vulnerability affects both the pure Python implementation and the C extension (cbor2). The C extension correctly uses Python's C-API for recursion protection (PyEnterRecursiveCall), but this mechanism is designed to prevent a stack overflow by raising a RecursionError. In some environments, this exception is not caught, thus causing the service process to terminate. - While the library handles moderate nesting, it lacks a configurable, data-driven depth limit independent of Python's global recursion setting. An attacker can supply a crafted CBOR payload containing thousands of nested arrays (e.g., 0x81). When cbor2.loads() attempts to parse this, it hits the interpreter's recursion limit, causing the call to raise a RecursionError. - By sending a stream of small (<100KB) malicious packets, an attacker can repeatedly crash…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3c37-wwvx-h642

  2. Revision 1 · created ·

    Published from osv record GHSA-3c37-wwvx-h642

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26209

Advisory: cbor2 has a Denial of Service via Uncontrolled Recursion in cbor2.loads
IDs: CVE-2026-26209, GHSA-3c37-wwvx-h642
Record: https://patchnext.com/advisories/cve-2026-26209 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cbor2 5.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cbor2: affected <= 5.8.0; fixed in 5.9.0

## Suggested inspection (read-only)
- `python -m pip show cbor2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cbor2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3c37-wwvx-h642 (OSV record GHSA-3c37-wwvx-h642 lists affected ranges: PyPI cbor2 >=0 <5.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3c37-wwvx-h642 (GitHub-reviewed advisory GHSA-3c37-wwvx-h642 lists affected ranges: PyPI cbor2 >=0 <=5.8.0)

Commands are suggestions: review each one before running it.

Loading voting…