opa-envoy-plugin has an Authorization Bypass via Double-Slash Path Misinterpretation in input.parsed_path
CVE-2026-26205GHSA-9f29-v6mm-pw6w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/open-policy-agent/opa-envoy-plugin 1.13.2-envoy-2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/open-policy-agent/opa-envoy-plugin
- Affected
- <= 1.13.1-envoy
- Fixed in
- 1.13.2-envoy-2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9f29-v6mm-pw6w lists affected ranges: Go github.com/open-policy-agent/opa-envoy-plugin >=0 <=1.13.1-envoy
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-26205: 0.53% estimated exploitation activity in the next 30 days; percentile 45.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security vulnerability has been discovered in how the input.parsedpath field is constructed. HTTP request paths are treated as full URIs when parsed; interpreting leading path segments prefixed with double slashes (//) as authority components, and therefore dropping them from the parsed path. This creates a path interpretation mismatch between authorization policies and backend servers, enabling attackers to bypass access controls by crafting requests where the authorization filter evaluates a different path than the one ultimately served. Attack example HTTP request: Policy sees: The leading //admin path segment is interpreted as an authority component, and dropped from input.parsedpath field: Backend receives: //admin/users path, normalized to /admin/users. Affected Request Pattern Examples | Request path | input.parsedpath | input.attributes.request.http.path | Discrepancy | | - | - | - | - | | / | [""] | / | ✅ None | | //foo | [""] | //foo| ❌ Mismatch | | /admin | ["admin"] |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9f29-v6mm-pw6w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26205 Advisory: opa-envoy-plugin has an Authorization Bypass via Double-Slash Path Misinterpretation in input.parsed_path IDs: CVE-2026-26205, GHSA-9f29-v6mm-pw6w Record: https://patchnext.com/advisories/cve-2026-26205 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/open-policy-agent/opa-envoy-plugin 1.13.2-envoy-2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/open-policy-agent/opa-envoy-plugin: affected <= 1.13.1-envoy; fixed in 1.13.2-envoy-2 ## Suggested inspection (read-only) - Go github.com/open-policy-agent/opa-envoy-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/open-policy-agent/opa-envoy-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9f29-v6mm-pw6w (GitHub-reviewed advisory GHSA-9f29-v6mm-pw6w lists affected ranges: Go github.com/open-policy-agent/opa-envoy-plugin >=0 <=1.13.1-envoy) Commands are suggestions: review each one before running it.
Loading voting…