ormar is vulnerable to SQL Injection through aggregate functions min() and max()
CVE-2026-26198GHSA-xxh2-68g9-8jqr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ormar 0.23.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ormar
- Affected
- >= 0.9.9, <= 0.22.0
- Fixed in
- 0.23.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xxh2-68g9-8jqr lists affected ranges: PyPI ormar >=0.9.9 <=0.22.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xxh2-68g9-8jqr lists affected ranges: PyPI ormar >=0.9.9 <0.23.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-26198: 1.01% estimated exploitation activity in the next 30 days; percentile 63.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Report of SQL Injection Vulnerability in Ormar ORM A SQL Injection attack can be achieved by passing a crafted string to the min() or max() aggregate functions. Brief description When performing aggregate queries, Ormar ORM constructs SQL expressions by passing user-supplied column names directly into sqlalchemy.text() without any validation or sanitization. The min() and max() methods in the QuerySet class accept arbitrary string input as the column parameter. While sum() and avg() are partially protected by an isnumeric type check that rejects non-existent fields, min() and max() skip this validation entirely. As a result, an attacker-controlled string is embedded as raw SQL inside the aggregate function call. Any unauthorized user can exploit this vulnerability to read the entire database contents, including tables unrelated to the queried model, by injecting a subquery as the column parameter. Affected versions The vulnerable SelectAction.gettextclause() method and the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xxh2-68g9-8jqr
- Revision 2 · amended ·
Amended from osv record GHSA-xxh2-68g9-8jqr
- Revision 1 · created ·
Published from ghsa record GHSA-xxh2-68g9-8jqr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26198 Advisory: ormar is vulnerable to SQL Injection through aggregate functions min() and max() IDs: CVE-2026-26198, GHSA-xxh2-68g9-8jqr Record: https://patchnext.com/advisories/cve-2026-26198 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ormar 0.23.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ormar: affected >= 0.9.9, <= 0.22.0; fixed in 0.23.0 ## Suggested inspection (read-only) - `python -m pip show ormar`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ormar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xxh2-68g9-8jqr (GitHub-reviewed advisory GHSA-xxh2-68g9-8jqr lists affected ranges: PyPI ormar >=0.9.9 <=0.22.0) - Verified: https://osv.dev/vulnerability/GHSA-xxh2-68g9-8jqr (OSV record GHSA-xxh2-68g9-8jqr lists affected ranges: PyPI ormar >=0.9.9 <0.23.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…