Open WebUI vulnerable to Stored XSS via iFrame in citations model
CVE-2026-26192GHSA-xc8p-9rr6-97r2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI open-webui
- Affected
- < 0.7.0
- Fixed in
- 0.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xc8p-9rr6-97r2 lists affected ranges: PyPI open-webui >=0 <0.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xc8p-9rr6-97r2 lists affected ranges: PyPI open-webui >=0 <0.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-26192: 0.23% estimated exploitation activity in the next 30 days; percentile 14.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Manually modifying chat history allows setting the html property within document metadata. This causes the frontend to enter a code path that treats document contents as HTML, and render them in an iFrame when the citation is previewed. This allows stored XSS via a weaponised document payload in a chat. The payload also executes when the citation is viewed on a shared chat. Details The vulnerability stems from how iFrame are implemented here: https://github.com/open-webui/open-webui/blob/6f1486ffd0cb288d0e21f41845361924e0d742b3/src/lib/components/chat/Messages/Citations/CitationModal.svelte#L163-L170 The html attribute can be controlled by a user who manually edits the chat history. Since allow-scripts and allow-same-origin are harcoded here the sandboxing offers essentially no protection. PoC Create an arbitrary chat with a file upload attached: <img width="2462" height="1148" alt="image" src="https://github.com/user-attachments/assets/fad83c74-036d-41b8-bc44-87bf2a538b21" /…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xc8p-9rr6-97r2
- Revision 1 · created ·
Published from osv record GHSA-xc8p-9rr6-97r2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26192 Advisory: Open WebUI vulnerable to Stored XSS via iFrame in citations model IDs: CVE-2026-26192, GHSA-xc8p-9rr6-97r2 Record: https://patchnext.com/advisories/cve-2026-26192 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI open-webui: affected < 0.7.0; fixed in 0.7.0 ## Suggested inspection (read-only) - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xc8p-9rr6-97r2 (OSV record GHSA-xc8p-9rr6-97r2 lists affected ranges: PyPI open-webui >=0 <0.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xc8p-9rr6-97r2 (GitHub-reviewed advisory GHSA-xc8p-9rr6-97r2 lists affected ranges: PyPI open-webui >=0 <0.7.0) Commands are suggestions: review each one before running it.
Loading voting…