Trivy Action has a script injection via sourced env file in composite action
CVE-2026-26189GHSA-9p44-j4g5-cfx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aquasecurity/trivy-action 0.34.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
GitHub Actions aquasecurity/trivy-action
- Affected
- >= 0.31.0, < 0.34.0
- Fixed in
- 0.34.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9p44-j4g5-cfx5 lists affected ranges: GitHub Actions aquasecurity/trivy-action >=0.31.0 <0.34.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-26189: 1.51% estimated exploitation activity in the next 30 days; percentile 74.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Command Injection in aquasecurity/trivy-action via Unsanitized Environment Variable Export A command injection vulnerability exists in aquasecurity/trivy-action due to improper handling of action inputs when exporting environment variables. The action writes export VAR=<input lines to trivyenvs.txt based on user-supplied inputs and subsequently sources this file in entrypoint.sh. Because input values are written without appropriate shell escaping, attacker-controlled input containing shell metacharacters (e.g., $(...), backticks, or other command substitution syntax) may be evaluated during the sourcing process. This can result in arbitrary command execution within the GitHub Actions runner context. Severity: Moderate CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N CWE-78: Improper Neutralization of Special Elements used in an OS Command (‘OS Command Injection’) Impact: Successful exploitation may lead to arbitrary command execution in the CI runner environment. Affected Versions:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9p44-j4g5-cfx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26189 Advisory: Trivy Action has a script injection via sourced env file in composite action IDs: CVE-2026-26189, GHSA-9p44-j4g5-cfx5 Record: https://patchnext.com/advisories/cve-2026-26189 (revision 1, source checked 26 Oct 2026, 17:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aquasecurity/trivy-action 0.34.0. A vendor fix does not mean a deployment is fixed. ## Affected components - GitHub Actions aquasecurity/trivy-action: affected >= 0.31.0, < 0.34.0; fixed in 0.34.0 ## Suggested inspection (read-only) - GitHub Actions aquasecurity/trivy-action: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aquasecurity/trivy-action. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9p44-j4g5-cfx5 (GitHub-reviewed advisory GHSA-9p44-j4g5-cfx5 lists affected ranges: GitHub Actions aquasecurity/trivy-action >=0.31.0 <0.34.0) Commands are suggestions: review each one before running it.
Loading voting…