Fleet has an SQL Injection vulnerability via backtick escape in ORDER BY parameter
CVE-2026-26186GHSA-49xw-vfc4-7p43
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 4.80.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/fleetdm/fleet/v4
- Affected
- < 4.80.1
- Fixed in
- 4.80.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-49xw-vfc4-7p43 lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <4.80.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-26186: 0.35% estimated exploitation activity in the next 30 days; percentile 28.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A SQL Injection vulnerability in Fleet’s software versions API allowed authenticated users to inject arbitrary SQL expressions via the orderkey query parameter. Due to unsafe use of goqu.I() when constructing the ORDER BY clause, specially crafted input could escape identifier quoting and be interpreted as executable SQL. Impact An authenticated attacker with access to the affected endpoint could inject SQL expressions into the underlying MySQL query. Although the injection occurs in an ORDER BY context, it is sufficient to enable blind SQL injection techniques that can disclose database information through conditional expressions that affect result ordering. Crafted expressions may also cause excessive computation or query failures, potentially leading to degraded performance or denial of service. No direct evidence of reliable data modification or stacked query execution was demonstrated. Workarounds If an immediate upgrade is not possible, users should restrict access to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-49xw-vfc4-7p43
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26186 Advisory: Fleet has an SQL Injection vulnerability via backtick escape in ORDER BY parameter IDs: CVE-2026-26186, GHSA-49xw-vfc4-7p43 Record: https://patchnext.com/advisories/cve-2026-26186 (revision 1, source checked 26 Oct 2026, 15:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 4.80.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fleetdm/fleet/v4: affected < 4.80.1; fixed in 4.80.1 ## Suggested inspection (read-only) - Go github.com/fleetdm/fleet/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fleetdm/fleet/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-49xw-vfc4-7p43 (GitHub-reviewed advisory GHSA-49xw-vfc4-7p43 lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <4.80.1) Commands are suggestions: review each one before running it.
Loading voting…