Skip to content

← Actionable
Medium, CVSS 5.3amended

Directus Vulnerable to User Enumeration via Password Reset Timing Attack

CVE-2026-26185GHSA-jr94-gj3h-c8rf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.14.1; @directus/api 32.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-26185: 0.39% estimated exploitation activity in the next 30 days; percentile 33.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A timing-based user enumeration vulnerability exists in the password reset functionality. When an invalid reseturl parameter is provided, the response time differs by approximately 500ms between existing and non-existing users, enabling reliable user enumeration. Details The password reset endpoint implements a timing protection mechanism to prevent user enumeration; however, URL validation executes before the timing protection is applied. This allows an attacker to distinguish between valid and invalid user accounts based on response timing differences. Impact This vulnerability violates user privacy and may facilitate targeted phishing attacks by allowing attackers to confirm the existence of user accounts.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jr94-gj3h-c8rf

  2. Revision 1 · created ·

    Published from osv record GHSA-jr94-gj3h-c8rf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26185

Advisory: Directus Vulnerable to User Enumeration via Password Reset Timing Attack
IDs: CVE-2026-26185, GHSA-jr94-gj3h-c8rf
Record: https://patchnext.com/advisories/cve-2026-26185 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.14.1; @directus/api 32.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.14.1; fixed in 11.14.1
- npm @directus/api: affected < 32.2.0; fixed in 32.2.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus, @directus/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jr94-gj3h-c8rf (OSV record GHSA-jr94-gj3h-c8rf lists affected ranges: npm directus >=0 =0 <32.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jr94-gj3h-c8rf (GitHub-reviewed advisory GHSA-jr94-gj3h-c8rf lists affected ranges: npm directus >=0 =0 <32.2.0)

Commands are suggestions: review each one before running it.

Loading voting…