CediPay Affected by Improper Input Validation in Payment Processing
CVE-2026-26063GHSA-wvr6-395c-5pxr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cedipay-core 1.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm cedipay-core
- Affected
- < 1.2.3
- Fixed in
- 1.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvr6-395c-5pxr lists affected ranges: npm cedipay-core >=0 <1.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvr6-395c-5pxr lists affected ranges: npm cedipay-core >=0 <1.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-26063: 0.31% estimated exploitation activity in the next 30 days; percentile 24.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in CediPay allows attackers to bypass input validation in the transaction API. Affected users: All deployments running versions prior to the patched release. Risk: Exploitation could result in unauthorized transactions, exposure of sensitive financial data, and compromise of payment integrity. Severity: High — potential financial loss and reputational damage. Patches The issue has been fixed in version 1.2.3. Users should upgrade to 1.2.3 or later immediately. All versions earlier than 1.2.3 remain vulnerable. Workarounds If upgrading is not immediately possible: Restrict API access to trusted networks or IP ranges. Enforce strict input validation at the application layer. Monitor transaction logs for anomalies or suspicious activity. These mitigations reduce exposure but do not fully eliminate the vulnerability. References OWASP Input Validation Guidelines (owasp.org in Bing) CWE-20: Improper Input Validation GitHub Security Advisory Documentation (docs.github.com in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wvr6-395c-5pxr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wvr6-395c-5pxr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26063 Advisory: CediPay Affected by Improper Input Validation in Payment Processing IDs: CVE-2026-26063, GHSA-wvr6-395c-5pxr Record: https://patchnext.com/advisories/cve-2026-26063 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cedipay-core 1.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm cedipay-core: affected < 1.2.3; fixed in 1.2.3 ## Suggested inspection (read-only) - `npm ls cedipay-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cedipay-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvr6-395c-5pxr (OSV record GHSA-wvr6-395c-5pxr lists affected ranges: npm cedipay-core >=0 <1.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-wvr6-395c-5pxr (GitHub-reviewed advisory GHSA-wvr6-395c-5pxr lists affected ranges: npm cedipay-core >=0 <1.2.3) Commands are suggestions: review each one before running it.
Loading voting…