Skip to content

← Actionable
Critical, CVSS 9.4amended

set-in Affected by Prototype Pollution

CVE-2026-26021GHSA-2c4m-g7rx-63q7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (set-in 2.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm set-in

    Affected
    >= 2.0.1, < 2.0.5
    Fixed in
    2.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-26021: 0.56% estimated exploitation activity in the next 30 days; percentile 46.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A prototype pollution vulnerability exists in the the npm package set-in (=2.0.1). Despite a previous fix that attempted to mitigate prototype pollution by checking whether user input contained a forbidden key, it is still possible to pollute Object.prototype via a crafted input using Array.prototype. This has been fixed in version 2.0.5. Details The vulnerability resides in line 28 of https://github.com/ahdinosaur/set-in/blob/master/index.js where includes() function is used to check whether user provided input contain forbidden strings. PoC Steps to reproduce 1. Install latest version of set-in using npm install or cloning from git 2. Run the following code snippet: Expected behavior Prototype pollution should be prevented and {} should not gain new properties. This should be printed on the console: Actual behavior Object.prototype is polluted This is printed on the console: Impact This is a prototype pollution vulnerability, which can have severe security implications…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-2c4m-g7rx-63q7

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-2c4m-g7rx-63q7

  4. Revision 1 · created ·

    Published from ghsa record GHSA-2c4m-g7rx-63q7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26021

Advisory: set-in Affected by Prototype Pollution
IDs: CVE-2026-26021, GHSA-2c4m-g7rx-63q7
Record: https://patchnext.com/advisories/cve-2026-26021 (revision 4, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: set-in 2.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm set-in: affected >= 2.0.1, < 2.0.5; fixed in 2.0.5

## Suggested inspection (read-only)
- `npm ls set-in --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on set-in.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2c4m-g7rx-63q7 (GitHub-reviewed advisory GHSA-2c4m-g7rx-63q7 lists affected ranges: npm set-in >=2.0.1 <2.0.5)
- Verified: https://osv.dev/vulnerability/GHSA-2c4m-g7rx-63q7 (OSV record GHSA-2c4m-g7rx-63q7 lists affected ranges: npm set-in >=2.0.1 <2.0.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…