Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization
CVE-2026-26016GHSA-g7vw-f8p5-c728
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pterodactyl/panel 1.12.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pterodactyl/panel
- Affected
- < 1.12.1
- Fixed in
- 1.12.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g7vw-f8p5-c728 lists affected ranges: Packagist pterodactyl/panel >=0 <1.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:L/SA:L · score source
- EPSS
- CVE-2026-26016: 0.36% estimated exploitation activity in the next 30 days; percentile 29.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A missing authorization check in multiple controllers allows any user with access to a node secret token to fetch information about any server on a Pterodactyl instance, even if that server is associated with a different node. This issue stems from missing logic to verify that the node requesting server data is the same node that the server is associated with. Any authenticated Wings node can retrieve server installation scripts (potentially containing secret values) and manipulate the installation status of servers belonging to other nodes. Wings nodes may also manipulate the transfer status of servers belonging to other nodes. This vulnerability requires a user to acquire a secret access token for a node. We rated this issue based on potential worst outcome. Unless a user gains access to a Wings secret access token they would not be able to access any of these vulnerable endpoints, as every endpoint requires a valid node access token. Details 1. The Remote API endpoint GET…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g7vw-f8p5-c728
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-26016 Advisory: Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization IDs: CVE-2026-26016, GHSA-g7vw-f8p5-c728 Record: https://patchnext.com/advisories/cve-2026-26016 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pterodactyl/panel 1.12.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pterodactyl/panel: affected < 1.12.1; fixed in 1.12.1 ## Suggested inspection (read-only) - Packagist pterodactyl/panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pterodactyl/panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g7vw-f8p5-c728 (GitHub-reviewed advisory GHSA-g7vw-f8p5-c728 lists affected ranges: Packagist pterodactyl/panel >=0 <1.12.1) Commands are suggestions: review each one before running it.
Loading voting…