Skip to content

← Actionable
Low, CVSS 3.7amended

LangChain affected by SSRF via image_url token counting in ChatOpenAI.get_num_tokens_from_messages

CVE-2026-26013GHSA-2g6r-c272-w58r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-core 1.2.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-26013: 0.43% estimated exploitation activity in the next 30 days; percentile 37.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Server-Side Request Forgery (SSRF) in ChatOpenAI Image Token Counting Summary The ChatOpenAI.getnumtokensfrommessages() method fetches arbitrary imageurl values without validation when computing token counts for vision-enabled models. This allows attackers to trigger Server-Side Request Forgery (SSRF) attacks by providing malicious image URLs in user input. Severity Low - The vulnerability allows SSRF attacks but has limited impact due to: - Responses are not returned to the attacker (blind SSRF) - Default 5-second timeout limits resource exhaustion - Non-image responses fail at PIL image parsing Impact An attacker who can control image URLs passed to getnumtokensfrommessages() can: - Trigger HTTP requests from the application server to arbitrary internal or external URLs - Cause the server to access internal network resources (private IPs, cloud metadata endpoints) - Cause minor resource consumption through image downloads (bounded by timeout) Note: This vulnerability occurs during…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2g6r-c272-w58r

  2. Revision 1 · created ·

    Published from osv record GHSA-2g6r-c272-w58r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26013

Advisory: LangChain affected by SSRF via image_url token counting in ChatOpenAI.get_num_tokens_from_messages
IDs: CVE-2026-26013, GHSA-2g6r-c272-w58r
Record: https://patchnext.com/advisories/cve-2026-26013 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langchain-core 1.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langchain-core: affected < 1.2.11; fixed in 1.2.11

## Suggested inspection (read-only)
- `python -m pip show langchain-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langchain-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2g6r-c272-w58r (OSV record GHSA-2g6r-c272-w58r lists affected ranges: PyPI langchain-core >=0 <1.2.11 (fixed))
- Verified: https://github.com/advisories/GHSA-2g6r-c272-w58r (GitHub-reviewed advisory GHSA-2g6r-c272-w58r lists affected ranges: PyPI langchain-core >=0 <1.2.11)

Commands are suggestions: review each one before running it.

Loading voting…