Skip to content

← Actionable
High, CVSS 8.6amended

FUXA Affected by a Path Traversal Sanitization Bypass

CVE-2026-25951GHSA-68m5-5w2h-h837

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.2.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-25951: 1.38% estimated exploitation activity in the next 30 days; percentile 72.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A flaw in the path sanitization logic allows an authenticated attacker with administrative privileges to bypass directory traversal protections. By using nested traversal sequences (e.g., ....//), an attacker can write arbitrary files to the server filesystem, including sensitive directories like runtime/scripts. This leads to Remote Code Execution (RCE) when the server reloads the malicious scripts. It is a new vulnerability a patch bypass for the sanitization in the last release . Details This report describes a new, distinct vulnerability that differs from previous Path Traversal advisories (such as CVE-2023-31718) in several ways: Patch Bypass (Regression): The vulnerability circumvents the existing sanitization logic implemented to fix previous traversal issues. The current "single-pass" regex approach is insufficient against nested sequences. Expansion of Scope: Unlike previous reports that focused primarily on /api/download, this bypass affects multiple critical…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-68m5-5w2h-h837

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-68m5-5w2h-h837

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25951

Advisory: FUXA Affected by a Path Traversal Sanitization Bypass
IDs: CVE-2026-25951, GHSA-68m5-5w2h-h837
Record: https://patchnext.com/advisories/cve-2026-25951 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuxa-server: affected <= 1.2.10; fixed in 1.2.11

## Suggested inspection (read-only)
- `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuxa-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-68m5-5w2h-h837 (OSV record GHSA-68m5-5w2h-h837 lists affected ranges: npm fuxa-server >=0 <1.2.11 (fixed))
- Verified: https://github.com/advisories/GHSA-68m5-5w2h-h837 (GitHub-reviewed advisory GHSA-68m5-5w2h-h837 lists affected ranges: npm fuxa-server >=0 <=1.2.10)

Commands are suggestions: review each one before running it.

Loading voting…