jsPDF has a PDF Injection in AcroForm module allows Arbitrary JavaScript Execution (RadioButton.createOption and "AS" property)
CVE-2026-25940GHSA-p5xg-68wr-hm3m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jspdf 4.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jspdf
- Affected
- < 4.2.0
- Fixed in
- 4.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p5xg-68wr-hm3m lists affected ranges: npm jspdf >=0 <4.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p5xg-68wr-hm3m lists affected ranges: npm jspdf >=0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-25940: 0.50% estimated exploitation activity in the next 30 days; percentile 42.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact User control of properties and methods of the Acroform module allows users to inject arbitrary PDF objects, such as JavaScript actions. If given the possibility to pass unsanitized input to the following property, a user can inject arbitrary PDF objects, such as JavaScript actions, which are executed when the victim hovers over the radio option. AcroformChildClass.appearanceState Example attack vector: Patches The vulnerability has been fixed in jsPDF@4.2.0. Workarounds Sanitize user input before passing it to the vulnerable API members.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p5xg-68wr-hm3m
- Revision 1 · created ·
Published from osv record GHSA-p5xg-68wr-hm3m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25940 Advisory: jsPDF has a PDF Injection in AcroForm module allows Arbitrary JavaScript Execution (RadioButton.createOption and "AS" property) IDs: CVE-2026-25940, GHSA-p5xg-68wr-hm3m Record: https://patchnext.com/advisories/cve-2026-25940 (revision 2, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jspdf 4.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jspdf: affected < 4.2.0; fixed in 4.2.0 ## Suggested inspection (read-only) - `npm ls jspdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jspdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p5xg-68wr-hm3m (OSV record GHSA-p5xg-68wr-hm3m lists affected ranges: npm jspdf >=0 <4.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-p5xg-68wr-hm3m (GitHub-reviewed advisory GHSA-p5xg-68wr-hm3m lists affected ranges: npm jspdf >=0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…