Skip to content

← Actionable
Critical, CVSS 9.3amended

FUXA Unauthenticated Remote Arbitrary Scheduler Write

CVE-2026-25939GHSA-c869-jx4c-q5fc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.2.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fuxa-server

    Affected
    >= 1.2.8, < 1.2.11
    Fixed in
    1.2.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H · score source
EPSS
  • CVE-2026-25939: 12.72% estimated exploitation activity in the next 30 days; percentile 96.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authorization bypass vulnerability in the FUXA allows an unauthenticated, remote attacker to create and modify arbitrary schedulers, exposing connected ICS/SCADA environments to follow-on actions. This vulnerability affects FUXA version 1.2.8 through version 1.2.10. This has been patched in FUXA version 1.2.11. Impact This affects all deployments, including those with runtime.settings.secureEnabled set to true. Exploitation allows an unauthenticated, remote attacker to automatically authenticate as guest and create, modify or delete schedules. These schedules can be configured to trigger immediately or cyclically, forcing connected devices to specific states or values, or executing existing scripts on the server. Patches This issue has been patched in FUXA version 1.2.11. Users are strongly encouraged to update to the latest available release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-c869-jx4c-q5fc

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-c869-jx4c-q5fc

  4. Revision 1 · created ·

    Published from ghsa record GHSA-c869-jx4c-q5fc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25939

Advisory: FUXA Unauthenticated Remote Arbitrary Scheduler Write
IDs: CVE-2026-25939, GHSA-c869-jx4c-q5fc
Record: https://patchnext.com/advisories/cve-2026-25939 (revision 4, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuxa-server: affected >= 1.2.8, < 1.2.11; fixed in 1.2.11

## Suggested inspection (read-only)
- `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuxa-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c869-jx4c-q5fc (GitHub-reviewed advisory GHSA-c869-jx4c-q5fc lists affected ranges: npm fuxa-server >=1.2.8 <1.2.11)
- Verified: https://osv.dev/vulnerability/GHSA-c869-jx4c-q5fc (OSV record GHSA-c869-jx4c-q5fc lists affected ranges: npm fuxa-server >=1.2.8 <1.2.11 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…