Skip to content

← Actionable
Medium, CVSS 5.9amended

unity-cli Exposes Plaintext Credentials in Debug Logs (sign-package command)

CVE-2026-25918GHSA-4255-c27h-62m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@rage-against-the-pixel/unity-cli 1.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-25918: 0.15% estimated exploitation activity in the next 30 days; percentile 4.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The sign-package command in @rage-against-the-pixel/unity-cli logs sensitive credentials in plaintext when the --verbose flag is used. Command-line arguments including --email and --password are output via JSON.stringify without sanitization, exposing secrets to shell history, CI/CD logs, and log aggregation systems. Users who run sign-package with --verbose and credential arguments expose their Unity account passwords. This affects all versions prior to 1.8.2. The vulnerability requires explicit user action (using --verbose) but creates significant risk in automated and shared environments. Workaround: Use environment variables (UNITYUSERNAME, UNITYPASSWORD) instead of command-line arguments, and avoid the --verbose flag when working with credentials. Existing RageAgainstThePixel and Buildalon GitHub actions are unaffected as they use the environment variables exclusively.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4255-c27h-62m5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4255-c27h-62m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25918

Advisory: unity-cli Exposes Plaintext Credentials in Debug Logs (sign-package command)
IDs: CVE-2026-25918, GHSA-4255-c27h-62m5
Record: https://patchnext.com/advisories/cve-2026-25918 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @rage-against-the-pixel/unity-cli 1.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @rage-against-the-pixel/unity-cli: affected < 1.8.2; fixed in 1.8.2

## Suggested inspection (read-only)
- `npm ls @rage-against-the-pixel/unity-cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @rage-against-the-pixel/unity-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4255-c27h-62m5 (OSV record GHSA-4255-c27h-62m5 lists affected ranges: npm @rage-against-the-pixel/unity-cli >=0 <1.8.2 (fixed))
- Verified: https://github.com/advisories/GHSA-4255-c27h-62m5 (GitHub-reviewed advisory GHSA-4255-c27h-62m5 lists affected ranges: npm @rage-against-the-pixel/unity-cli >=0 <1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…