Skip to content

← Actionable
Critical, CVSS 9.3amended

fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names

CVE-2026-25896GHSA-m7jm-9gc2-mpf2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 5.3.5, 4.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fast-xml-parser

    Affected
    >= 5.0.0, < 5.3.5>= 4.1.3, < 4.5.4
    Fixed in
    4.5.4, 5.3.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2026-25896: 0.53% estimated exploitation activity in the next 30 days; percentile 44.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Entity encoding bypass via regex injection in DOCTYPE entity names Summary A dot (.) in a DOCTYPE entity name is treated as a regex wildcard during entity replacement, allowing an attacker to shadow built-in XML entities (&lt;, &gt;, &amp;, &quot;, &apos;) with arbitrary values. This bypasses entity encoding and leads to XSS when parsed output is rendered. Details The fix for CVE-2023-34104 addressed some regex metacharacters in entity names but missed . (period), which is valid in XML names per the W3C spec. In DocTypeReader.js, entity names are passed directly to RegExp(): An entity named l. produces the regex /&l.;/g where . matches any character, including the t in &lt;. Since DOCTYPE entities are replaced before built-in entities, this shadows &lt; entirely. The same issue exists in OrderedObjParser.js:81 (addExternalEntities), and in the v6 codebase - EntitiesParser.js has a validateEntityName function with a character blacklist, but . is not included: Shadowing all 5 built-in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m7jm-9gc2-mpf2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-m7jm-9gc2-mpf2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-m7jm-9gc2-mpf2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25896

Advisory: fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names
IDs: CVE-2026-25896, GHSA-m7jm-9gc2-mpf2
Record: https://patchnext.com/advisories/cve-2026-25896 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 5.3.5, 4.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fast-xml-parser: affected >= 5.0.0, < 5.3.5; >= 4.1.3, < 4.5.4; fixed in 4.5.4, 5.3.5

## Suggested inspection (read-only)
- `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fast-xml-parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m7jm-9gc2-mpf2 (GitHub-reviewed advisory GHSA-m7jm-9gc2-mpf2 lists affected ranges: npm fast-xml-parser >=5.0.0 =4.1.3 <4.5.4)
- Verified: https://osv.dev/vulnerability/GHSA-m7jm-9gc2-mpf2 (OSV record GHSA-m7jm-9gc2-mpf2 lists affected ranges: npm fast-xml-parser >=5.0.0 =4.1.3 <4.5.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…