Skip to content

← Actionable
Critical, CVSS 9.5amended

FUXA Unauthenticated Remote Code Execution via Arbitrary File Write in Upload API

CVE-2026-25895GHSA-88qh-cphv-996c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.2.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-25895: 13.03% estimated exploitation activity in the next 30 days; percentile 96.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Description A path traversal vulnerability in FUXA allows an unauthenticated, remote attacker to write arbitrary files to arbitrary locations on the server filesystem. This affects FUXA through version 1.2.9. This issue has been patched in FUXA version 1.2.10. Impact This affects all deployments, including those with runtime.settings.secureEnabled set to true. Exploitation allows an unauthenticated, remote attacker to overwrite application and system files. If the attacker can overwrite application code, startup scripts, or configuration files that are later executed/loaded, RCE is likely. Depending on deployment configuration and permissions, this may lead to full system compromise and could further expose connected ICS/SCADA environments to follow-on actions. Patches This issue has been patched in FUXA version 1.2.10. Users are strongly encouraged to update to the latest available release. Notes GitHub stated this vulnerability is identical to CVE-2025-69981, which was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-88qh-cphv-996c

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-88qh-cphv-996c

  4. Revision 1 · created ·

    Published from ghsa record GHSA-88qh-cphv-996c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-25895

Advisory: FUXA Unauthenticated Remote Code Execution via Arbitrary File Write in Upload API
IDs: CVE-2026-25895, GHSA-88qh-cphv-996c
Record: https://patchnext.com/advisories/cve-2026-25895 (revision 4, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.2.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fuxa-server: affected <= 1.2.9; fixed in 1.2.10

## Suggested inspection (read-only)
- `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fuxa-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-88qh-cphv-996c (GitHub-reviewed advisory GHSA-88qh-cphv-996c lists affected ranges: npm fuxa-server >=0 <=1.2.9)
- Verified: https://osv.dev/vulnerability/GHSA-88qh-cphv-996c (OSV record GHSA-88qh-cphv-996c lists affected ranges: npm fuxa-server >=0 <1.2.10 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…