FUXA Unauthenticated Remote Code Execution via Hardcoded JWT Secret in Default Configuration
CVE-2026-25894GHSA-32cc-x95p-fxcg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fuxa-server 1.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fuxa-server
- Affected
- <= 1.2.9
- Fixed in
- 1.2.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-32cc-x95p-fxcg lists affected ranges: npm fuxa-server >=0 <=1.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-32cc-x95p-fxcg lists affected ranges: npm fuxa-server >=0 <1.2.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.5 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-25894: 0.85% estimated exploitation activity in the next 30 days; percentile 58.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description An insecure default configuration in FUXA allows an unauthenticated, remote attacker to gain administrative access and execute arbitrary code on the server. This affects FUXA through version 1.2.9 when authentication is enabled, but the administrator JWT secret is not configured. This issue has been patched in FUXA version 1.2.10. Impact The FUXA documentation allows administrators to manually update a hardcoded JWT secret when enabling authentication. This feature was not available in the UI. This results in a fail-open security posture, where the application can report or appear to be operating in secureEnabled mode while still accepting tokens signed with a publicly known key. Exploitation allows an unauthenticated, remote attacker to forge JWTs to bypass all authentication mechanisms and obtain administrative access to the FUXA instance. With these elevated privileges, the attacker can interact with administrative APIs, including intended features designed for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-32cc-x95p-fxcg
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-32cc-x95p-fxcg
- Revision 1 · created ·
Published from ghsa record GHSA-32cc-x95p-fxcg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25894 Advisory: FUXA Unauthenticated Remote Code Execution via Hardcoded JWT Secret in Default Configuration IDs: CVE-2026-25894, GHSA-32cc-x95p-fxcg Record: https://patchnext.com/advisories/cve-2026-25894 (revision 4, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fuxa-server 1.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fuxa-server: affected <= 1.2.9; fixed in 1.2.10 ## Suggested inspection (read-only) - `npm ls fuxa-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fuxa-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-32cc-x95p-fxcg (GitHub-reviewed advisory GHSA-32cc-x95p-fxcg lists affected ranges: npm fuxa-server >=0 <=1.2.9) - Verified: https://osv.dev/vulnerability/GHSA-32cc-x95p-fxcg (OSV record GHSA-32cc-x95p-fxcg lists affected ranges: npm fuxa-server >=0 <1.2.10 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…